summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2019-02-21 00:18:17 +0100
committerGianluca Boiano2019-02-21 00:18:17 +0100
commitb29d8a7d126618fb7d25894e8cb93bcb39aeace5 (patch)
tree41f34bf450be1ae771acdcd6017730b8e2f6e036
parentcc0f1fa27113331b1c75fe7da9ac4b3477f29540 (diff)
downloadaur-b29d8a7d126618fb7d25894e8cb93bcb39aeace5.tar.gz
soulseekqt: fixed right click issue and using entire AppImage runtime
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
-rw-r--r--selinux-mock.c5
-rw-r--r--soulseekqt.sh4
4 files changed, 31 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52276fc2c394..1eed1272eb60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = soulseekqt
pkgdesc = A desktop client for the Soulseek peer-to-peer file sharing network
pkgver = 20180130
- pkgrel = 2
+ pkgrel = 3
url = http://www.soulseekqt.net/news/
arch = x86_64
license = CUSTOM
@@ -9,9 +9,14 @@ pkgbase = soulseekqt
depends = libxext
depends = libxrender
depends = qt5-multimedia
+ options = !strip
source = https://www.dropbox.com/s/0vi87eef3ooh7iy/SoulseekQt-2018-1-30-64bit.tgz
+ source = selinux-mock.c
+ source = soulseekqt.sh
source = soulseekqt.desktop
md5sums = 1d98331893bc9b9d45ba34f6523353ab
+ md5sums = 4ed42be654289fc9cd7f4181c363f745
+ md5sums = a95f77dbfe0b714b31866273ff47a206
md5sums = 810a4200a3c8568257b66b6bdea5c29c
pkgname = soulseekqt
diff --git a/PKGBUILD b/PKGBUILD
index e532e50cb775..652d6e433021 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,27 +6,37 @@
pkgname=soulseekqt
pkgver=20180130
_pkgver=2018-1-30
-pkgrel=2
+pkgrel=3
pkgdesc="A desktop client for the Soulseek peer-to-peer file sharing network"
arch=('x86_64')
url="http://www.soulseekqt.net/news/"
license=('CUSTOM')
depends=('fontconfig' 'libxext' 'libxrender' 'qt5-multimedia')
source=("https://www.dropbox.com/s/0vi87eef3ooh7iy/SoulseekQt-${_pkgver}-64bit.tgz"
+ selinux-mock.c
+ soulseekqt.sh
$pkgname.desktop
)
+options=("!strip")
package () {
cd $srcdir
+ msg2 "Extraction..."
./SoulseekQt-${_pkgver}-64bit.AppImage --appimage-extract
- cd squashfs-root
+ msg2 "Compiling libselinux.so.1 fakelib"
+ gcc -s -shared -o libselinux.so.1 -Wl,-soname,libselinux.so.1 selinux-mock.c
- install -vDm755 SoulseekQt "$pkgdir/usr/bin/$pkgname"
- install -vDm644 soulseek.png "$pkgdir/usr/share/pixmaps/soulseek.png"
- install -vDm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ msg2 "Installing assets..."
+ install -vDm755 "SoulseekQt-${_pkgver}-64bit.AppImage" "$pkgdir/opt/soulseekqt/$pkgname.AppImage"
+ install -vDm755 libselinux.so.1 "$pkgdir/opt/soulseekqt/libselinux.so.1"
+ install -vDm755 soulseekqt.sh "$pkgdir/usr/bin/$pkgname"
+ install -vDm644 squashfs-root/soulseek.png "$pkgdir/usr/share/pixmaps/soulseek.png"
+ install -vDm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}
md5sums=('1d98331893bc9b9d45ba34f6523353ab'
- '810a4200a3c8568257b66b6bdea5c29c')
+ '4ed42be654289fc9cd7f4181c363f745'
+ 'a95f77dbfe0b714b31866273ff47a206'
+'810a4200a3c8568257b66b6bdea5c29c')
diff --git a/selinux-mock.c b/selinux-mock.c
new file mode 100644
index 000000000000..574d994d70e1
--- /dev/null
+++ b/selinux-mock.c
@@ -0,0 +1,5 @@
+extern int is_selinux_enabled(void)
+{
+ /* always return 0; this way we don't trigger any SELINUX calls */
+ return 0;
+}
diff --git a/soulseekqt.sh b/soulseekqt.sh
new file mode 100644
index 000000000000..3f44b3d466c2
--- /dev/null
+++ b/soulseekqt.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+LD_PRELOAD=/usr/lib/libfreetype.so.6 \
+LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/opt/soulseekqt \
+/opt/soulseekqt/soulseekqt.AppImage