summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2018-08-24 18:56:15 +0100
committerEarnestly2018-08-24 18:56:15 +0100
commit3e308973294585261fba7c3d0b540f816cf0d623 (patch)
treee9f7c6ef427e2baa1468dda09c1b90013b26d86b
parent02d26fa13eb16480d243784b7f3c9355e827a99c (diff)
downloadaur-sparforte-git.tar.gz
sparforte: use SOURCE_DATE_EPOCH and other fixes
This disables mysql support for APQ since it appears to be having issues with source units not being expanded with proper values resulting in syntax errors. This also removes parser.adb from prepare (via config.linux) since it was clobbering the file. Recently sparforte is embedding timestamps in the source (sigh). This reimplements their logic but accepting SOURCE_DATE_EPOCH if available.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xconfig.linux24
3 files changed, 24 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ba26bf1ca1c..79b286e5b0e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sparforte-git
pkgdesc = shell and scripting language formally known as bush
- pkgver = 2.1.r31.ga05bf87
- pkgrel = 2
+ pkgver = 2.1.r181.g8feee7e
+ pkgrel = 1
url = http://www.sparforte.com
arch = i686
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = sparforte-git
source = git+https://github.com/kburtch/SparForte
source = config.linux
sha256sums = SKIP
- sha256sums = 139639a486cb9c85fa06a89b16db33eff20e800007aa0eb8811556bb0a26b866
+ sha256sums = 6c7539230e5b0542154e5943ae3be2b244477b4929ad20f75a2e052517bae656
pkgname = sparforte-git
diff --git a/PKGBUILD b/PKGBUILD
index 2702f1dbbd6d..d760c86ca55a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=sparforte-git
-pkgver=2.1.r31.ga05bf87
-pkgrel=2
+pkgver=2.1.r181.g8feee7e
+pkgrel=1
pkgdesc='shell and scripting language formally known as bush'
url='http://www.sparforte.com'
@@ -17,7 +17,7 @@ source=('git+https://github.com/kburtch/SparForte'
'config.linux')
sha256sums=('SKIP'
- '139639a486cb9c85fa06a89b16db33eff20e800007aa0eb8811556bb0a26b866')
+ '6c7539230e5b0542154e5943ae3be2b244477b4929ad20f75a2e052517bae656')
pkgver() {
cd SparForte
diff --git a/config.linux b/config.linux
index 71ccc58f1b6b..fe33112301cf 100755
--- a/config.linux
+++ b/config.linux
@@ -8,6 +8,7 @@
# and other damage sparforte's configure script can do such as calling sudo.
readonly startdir=$PWD
+SOURCE_DATE_EPOCH=${SOURCE_DATE_EPOCH:-$(date +%s)}
CC=gcc
CPU_FLAG=-march
@@ -24,14 +25,22 @@ prepare() {
local ext=${1##*.}
printf -- '%s: updating...\n' "$1"
cp -- "$1".orig temp."$ext"
- if gnatprep -DPOSTGRES=true -DMYSQL=false -DOPENGL=true -DREADLINE=true -DSOUND=false \
- -DGCGI=false -DBDB=false -DAPQ=true temp."$ext" "$1" 2> /dev/null; then
+ if gnatprep -DconfigbuildDate="\"$(date -d @"$SOURCE_DATE_EPOCH" +%y%m%d)\"" \
+ -Dconfigreleased=false \
+ -DPOSTGRES=true \
+ -DMYSQL=false \
+ -DOPENGL=true \
+ -DREADLINE=true \
+ -DSOUND=false \
+ -DGCGI=false \
+ -DBDB=false \
+ -DAPQ=true temp."$ext" "$1" 2> /dev/null; then
+ chmod 0444 "$1"
rm -- temp."$ext" 2> /dev/null
fi
}
cd "$startdir"
-
cp -v src/os_bindings/spar_linux.ads src/spar_os.ads
cp -v src/scanner-calendar-latest.ads src/scanner-calendar.ads
cp -v src/scanner-calendar-latest.adb src/scanner-calendar.adb
@@ -75,10 +84,14 @@ APQINCLSSUB='-I./apq-2.1'
# readline
RLINCL='-I./areadline'
-RLLIBS='-lreadline'
+RLLIBS='-lreadline -lhistory'
+# disable mysql support since it seems to include nonsense code:
+# apq-mysql.ads:38:24: identifier expected
+# apq-mysql.ads:40:23: aggregate may not have single positional component
+# apq-mysql.ads:40:24: missing operand
cd "$startdir"/src/apq-2.1
-HAVE_PG=1 ./configure
+HAVE_MY=0 ./configure
touch c_gstreamer.c
@@ -87,7 +100,6 @@ prepare world.ads
prepare user_io-getline.adb
prepare scanner_res.adb
prepare scanner_res.ads
-prepare parser.adb
prepare builtins.adb
prepare parser_db.adb
prepare parser_dbm.adb