summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasile Vilvoiu2023-05-06 21:36:13 +0300
committerVasile Vilvoiu2023-05-06 21:36:13 +0300
commit576dd48a331fa901d40bdb2e8316f5297b099cad (patch)
tree6624765b20393a735fe2575b6a2eec500a2b2045
parent96aa95793dd4bc2319c9c45b86f54c491c69aae1 (diff)
downloadaur-specgram.tar.gz
v0.9.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--fix_build.patch24
3 files changed, 7 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9118feda7155..7644a3dcc7ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = specgram
pkgdesc = Small program that computes and plots spectrograms, either in a live window or to disk, with support for stdin input.
- pkgver = 0.9.2
- pkgrel = 2
+ pkgver = 0.9.3
+ pkgrel = 1
url = https://github.com/rimio/specgram
arch = x86_64
license = MIT
@@ -10,7 +10,7 @@ pkgbase = specgram
depends = sfml
depends = fftw
conflicts = specgram-git
- source = https://github.com/rimio/specgram/archive/v0.9.2.tar.gz
- md5sums = 2f642bcf9b7bc13fa47afc52eae9f987
+ source = https://github.com/rimio/specgram/archive/v0.9.3.tar.gz
+ md5sums = 030239b5b1f38714090d3226974a9642
pkgname = specgram
diff --git a/PKGBUILD b/PKGBUILD
index 5949e30c3a54..dc228b82f758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vasile Vilvoiu <vasi.vilvoiu@gmail.com>
pkgname=specgram
-pkgver=0.9.2
-pkgrel=2
+pkgver=0.9.3
+pkgrel=1
pkgdesc="Small program that computes and plots spectrograms, either in a live window or to disk, with support for stdin input."
arch=('x86_64')
url="https://github.com/rimio/specgram"
@@ -10,12 +10,7 @@ depends=('sfml' 'fftw')
makedepends=('cmake' 'gcc')
conflicts=('specgram-git')
source=("https://github.com/rimio/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=("2f642bcf9b7bc13fa47afc52eae9f987")
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch --forward --strip=1 --input="../../fix_build.patch"
-}
+md5sums=("030239b5b1f38714090d3226974a9642")
build() {
cd "$pkgname-$pkgver"
diff --git a/fix_build.patch b/fix_build.patch
deleted file mode 100644
index b0909ee7193a..000000000000
--- a/fix_build.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/src/fft.cpp b/src/fft.cpp
-index f00dd4f..d5fa4c2 100644
---- a/src/fft.cpp
-+++ b/src/fft.cpp
-@@ -6,6 +6,7 @@
- */
- #include "fft.hpp"
-
-+#include <algorithm>
- #include <cassert>
- #include <cstring>
- #include <cmath>
-diff --git a/src/value-map.cpp b/src/value-map.cpp
-index 51e3944..2e1138a 100644
---- a/src/value-map.cpp
-+++ b/src/value-map.cpp
-@@ -5,6 +5,7 @@
- * it under the terms of the MIT license. See LICENSE for details.
- */
- #include "value-map.hpp"
-+#include <algorithm>
- #include <cmath>
-
- ValueMap::ValueMap(double lower, double upper, const std::string& unit) : lower_(lower), upper_(upper), unit_(unit)