summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2018-03-17 01:19:45 -0400
committerJames An2018-03-17 01:19:45 -0400
commit4ed411264774020b19d7833d4239f1277876ff2b (patch)
tree6421dd1ad09f413b6684e16c4a7154f6a1d82233
parentb52f2d4309b9b54e278c257b310ef1f8a8704549 (diff)
downloadaur-speedtest-cli-git.tar.gz
Updated to latest upstream commit and cleaned up the PKGBUILD.
Changed the target branch from devel to master.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ad94119d562..42f4361e15f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Jan 19 22:10:45 UTC 2016
pkgbase = speedtest-cli-git
- pkgdesc = Command line interface for testing internet bandwidth using speedtest.net - git devel branch
- pkgver = 0.3.4.r0.g7b09d87
+ pkgdesc = Command line interface for testing internet bandwidth using speedtest.net
+ pkgver = 2.0.0.r0.g0a7823d
pkgrel = 1
url = https://github.com/sivel/speedtest-cli
arch = any
@@ -10,9 +8,9 @@ pkgbase = speedtest-cli-git
makedepends = git
makedepends = python-setuptools
depends = python
- provides = speedtest-cli
+ provides = speedtest-cli=2.0.0.r0.g0a7823d
conflicts = speedtest-cli
- source = speedtest-cli::git+https://github.com/sivel/speedtest-cli.git#branch=devel
+ source = speedtest-cli::git+https://github.com/sivel/speedtest-cli.git
md5sums = SKIP
pkgname = speedtest-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index 9ea5b513ea72..c0d36aac2614 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
# Maintainer: James An <james@jamesan.ca>
-_pkgname=speedtest-cli
-pkgname="$_pkgname-git"
-pkgver=0.3.4.r0.g7b09d87
+pkgname=speedtest-cli-git
+_pkgname=${pkgname%-git}
+pkgver=2.0.0.r0.g0a7823d
pkgrel=1
-pkgdesc='Command line interface for testing internet bandwidth using speedtest.net - git devel branch'
+pkgdesc='Command line interface for testing internet bandwidth using speedtest.net'
arch=('any')
url="https://github.com/sivel/$_pkgname"
license=('Apache')
depends=('python')
makedepends=('git' 'python-setuptools')
-provides=("$_pkgname")
+provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("$_pkgname"::"git+https://github.com/sivel/$_pkgname.git#branch=devel")
+source=("$_pkgname"::"git+https://github.com/sivel/$_pkgname.git")
md5sums=('SKIP')
pkgver() {
cd $_pkgname
(
set -o pipefail
- git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^v//' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- ) | sed 's/^v//' # remove leading letter v
+ )
}
package(){
cd $_pkgname
- python setup.py install install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1
}