summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-06-13 15:19:37 +0200
committerMarco Pompili2015-06-13 15:19:37 +0200
commit0fe40d1828be39bdc699b9b57fe5ba791ce485bd (patch)
treeb14a1d3081aab17b116f4f468c3bf023f3fd9859
downloadaur-0fe40d1828be39bdc699b9b57fe5ba791ce485bd.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a40a8f305aa0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sphinxbase
+ pkgdesc = Common library for sphinx speech recognition.
+ pkgver = 0.8
+ pkgrel = 4
+ url = http://cmusphinx.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = bison
+ depends = python2
+ depends = cython2
+ depends = lapack
+ depends = alsa-lib
+ depends = libpulse
+ depends = libsamplerate
+ options = !libtool
+ source = http://downloads.sourceforge.net/cmusphinx/sphinxbase-0.8.tar.gz
+ md5sums = 7335d233f7ad4ecc4b508aec7b5dc101
+
+pkgname = sphinxbase
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..925e4b5f673d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Marco Pompili marcs.pompili@gmail.com
+# Contributor: Giorgio Gilestro crocowhile@gmail.com
+
+pkgname=sphinxbase
+pkgver=0.8
+pkgrel=4
+pkgdesc='Common library for sphinx speech recognition.'
+url='http://cmusphinx.sourceforge.net/'
+arch=('i686' 'x86_64')
+license=('BSD')
+options=('!libtool')
+makedepends=('bison')
+depends=('python2' 'cython2' 'lapack' 'alsa-lib' 'libpulse' 'libsamplerate')
+source=("http://downloads.sourceforge.net/cmusphinx/$pkgname-$pkgver.tar.gz")
+md5sums=('7335d233f7ad4ecc4b508aec7b5dc101')
+_pythondir="$pkgdir/usr/lib/python2.7/site-packages"
+
+build() {
+ cd $pkgname-$pkgver
+
+ find -type f -exec sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' {} \;
+ find -type f -exec sed -i 's_/usr/bin/python_/usr/bin/python2_' {} \;
+ find -type f -exec sed -i 's_python -c_python2 -c_' {} \;
+ find -type f -exec sed -i 's_python-config_python2-config_' {} \;
+ find -type f -exec sed -i 's_cython_cython2_' {} \;
+
+ export PYTHON=/usr/bin/python2
+ export PYTHON_CONFIG=/usr/bin/python2-config
+
+ ./configure --prefix=/usr --with-python=/usr/bin/python2
+
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ install -d $_pythondir
+ PYTHONPATH=$_pythondir make DESTDIR="$pkgdir" install
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/"
+}