summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-09-28 15:49:32 +0200
committerMarco Pompili2015-09-28 15:49:32 +0200
commit230289cfe7ad822415e7015e3e4972374cfa7f04 (patch)
treea453dfc8504a8a06b9c1e809c40969dfd46653ea
parent0fe40d1828be39bdc699b9b57fe5ba791ce485bd (diff)
downloadaur-230289cfe7ad822415e7015e3e4972374cfa7f04.tar.gz
Version 5-prealpha
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 31 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a40a8f305aa0..159c1a261334 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = sphinxbase
pkgdesc = Common library for sphinx speech recognition.
- pkgver = 0.8
- pkgrel = 4
+ pkgver = 5prealpha
+ pkgrel = 1
url = http://cmusphinx.sourceforge.net/
arch = i686
arch = x86_64
- license = BSD
+ license = BSD-2
makedepends = bison
depends = python2
depends = cython2
+ depends = swig
depends = lapack
depends = alsa-lib
depends = libpulse
depends = libsamplerate
options = !libtool
- source = http://downloads.sourceforge.net/cmusphinx/sphinxbase-0.8.tar.gz
- md5sums = 7335d233f7ad4ecc4b508aec7b5dc101
+ source = http://downloads.sourceforge.net/project/cmusphinx/sphinxbase/5prealpha/sphinxbase-5prealpha.tar.gz
+ source = https://raw.githubusercontent.com/cmusphinx/sphinxbase/master/LICENSE
+ md5sums = 12acdeda1d597631947e5531463431f1
+ md5sums = 469fd92fa8cd1d4ca7ee0fe7435af689
pkgname = sphinxbase
diff --git a/PKGBUILD b/PKGBUILD
index 925e4b5f673d..aed779d259d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
-# Maintainer: Marco Pompili marcs.pompili@gmail.com
+# Maintainer: Marco Pompili < marcs (dot) pompili (at) gmail (dot) com >
# Contributor: Giorgio Gilestro crocowhile@gmail.com
pkgname=sphinxbase
-pkgver=0.8
-pkgrel=4
+pkgver=5prealpha
+pkgrel=1
pkgdesc='Common library for sphinx speech recognition.'
url='http://cmusphinx.sourceforge.net/'
arch=('i686' 'x86_64')
-license=('BSD')
+license=('BSD-2')
options=('!libtool')
makedepends=('bison')
-depends=('python2' 'cython2' 'lapack' 'alsa-lib' 'libpulse' 'libsamplerate')
-source=("http://downloads.sourceforge.net/cmusphinx/$pkgname-$pkgver.tar.gz")
-md5sums=('7335d233f7ad4ecc4b508aec7b5dc101')
+depends=('python2' 'cython2' 'swig' 'lapack' 'alsa-lib' 'libpulse' 'libsamplerate')
+source=("http://downloads.sourceforge.net/project/cmusphinx/${pkgname}/${pkgver}/$pkgname-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/cmusphinx/sphinxbase/master/LICENSE")
+md5sums=('12acdeda1d597631947e5531463431f1'
+ '469fd92fa8cd1d4ca7ee0fe7435af689')
_pythondir="$pkgdir/usr/lib/python2.7/site-packages"
build() {
cd $pkgname-$pkgver
+ msg2 "Reconfiguring project for Automake v1.15"
+ autoreconf -ivf > /dev/null
+
+ msg2 "Setting python2 as the python installtion for ${pkgname}"
+
find -type f -exec sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' {} \;
find -type f -exec sed -i 's_/usr/bin/python_/usr/bin/python2_' {} \;
find -type f -exec sed -i 's_python -c_python2 -c_' {} \;
@@ -27,7 +34,9 @@ build() {
export PYTHON=/usr/bin/python2
export PYTHON_CONFIG=/usr/bin/python2-config
- ./configure --prefix=/usr --with-python=/usr/bin/python2
+ msg2 "Building..."
+
+ ./configure --prefix=/usr
make
}
@@ -39,5 +48,9 @@ package() {
PYTHONPATH=$_pythondir make DESTDIR="$pkgdir" install
install -d "$pkgdir/usr/share/licenses/$pkgname"
- install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/"
-}
+
+ install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ libtool --finish "$pkgdir/usr/lib"
+ libtool --finish "$pkgdir/usr/lib/python2.7/site-packages/sphinxbase"
+}