summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2017-08-09 20:30:59 +0200
committerUffe Jakobsen2017-08-09 20:30:59 +0200
commit6ccca4b6f2421a1f0c4f9bf749e1159904642623 (patch)
tree66d2b2a9688a37c8e8d2c069a372c9ff9a08e595
downloadaur-spin2cpp.tar.gz
Initial
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc4f7c243ccc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Aug 9 18:30:20 UTC 2017
+pkgbase = spin2cpp
+ pkgdesc = Tool to convert Parallax Propeller Spin code to PASM, C++ or C
+ pkgver = 3.6.3
+ pkgrel = 1
+ url = https://github.com/totalspectrum/spin2cpp
+ arch = x86_64
+ arch = i686
+ license = unknown
+ optdepends = tcl
+ optdepends = tk
+ provides = spin2cpp
+ conflicts = spin2cpp-git
+ source = https://github.com/totalspectrum/spin2cpp/archive/v3.6.3.tar.gz
+ md5sums = 579f55984356464682aeb4439fd3cd41
+
+pkgname = spin2cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..666532e9c1ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Uffe Jakobsen _<_uffe_at_uffe_dot_org_>_
+pkgname=spin2cpp
+_pkgname=spin2cpp
+pkgver=3.6.3
+pkgrel=1
+pkgdesc="Tool to convert Parallax Propeller Spin code to PASM, C++ or C"
+arch=('x86_64' 'i686')
+url="https://github.com/totalspectrum/spin2cpp"
+license=('unknown')
+groups=()
+optdepends=("tcl" "tk")
+makedepends=()
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+replaces=()
+backup=()
+options=()
+install=
+source=("https://github.com/totalspectrum/${_pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('579f55984356464682aeb4439fd3cd41')
+
+
+build()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make
+}
+
+package()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -Dm 755 "build/spin2cpp" "${pkgdir}/usr/bin/spin2cpp"
+ install -Dm 755 "build/fastspin" "${pkgdir}/usr/bin/fastspin"
+ install -Dm 755 "spinconvert/spinconvert.tcl" "${pkgdir}/usr/bin/spinconvert"
+}
+
+#
+# EOF
+#