aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Pigozzi2017-11-16 22:47:46 +0100
committerStefano Pigozzi2021-04-27 20:44:50 +0200
commit7db346053a1e5758f6a410281bbd8187a5e804d4 (patch)
tree0cceded83790ae233d9a54d85e3df97006d2ee69
downloadaur-spiral-knights-steam.tar.gz
✨ First (rebased) commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD85
-rw-r--r--README.md10
-rw-r--r--extra.txt7
-rwxr-xr-xlibsteam_api.sobin0 -> 66598 bytes
-rw-r--r--spiral-knights.desktop8
-rw-r--r--spiral-knights.pngbin0 -> 23200 bytes
-rwxr-xr-xspiral3228
-rw-r--r--steam_appid.txt1
10 files changed, 170 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d898466709e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = spiral-knights-steam
+ pkgdesc = Spiral Knights Linux client with Steam support
+ pkgver = 1
+ pkgrel = 1
+ url = https://store.steampowered.com/app/99900/Spiral_Knights/
+ arch = x86_64
+ license = unknown
+ depends = xdg-utils
+ depends = bin32-jre
+ depends = steam
+ source = spiral-knights.desktop
+ source = spiral-knights.png
+ source = steam_appid.txt
+ source = libsteam_api.so
+ source = extra.txt
+ source = spiral32
+ sha512sums = b45f60b9a257d0a1aa4593bdb73b9454b467eef6f588225d5d7188be5a06db2254ba61b6e4ef8f7f61f65dc5949f9c2836623bdce905204b9b93d0e253395248
+ sha512sums = 08d5165d510755ea84ebe189803dbf66e50efd0c5b35d92b48a164f593544bce85b2852e24a41d218c733116e93994e315cafa677b8dc62d2d163a35687c52d8
+ sha512sums = 35b91557cb0c4521833bb181ad344e64364e524597d91c0533df4c974254039ca6f63d45936c75fdc3383d91b901fab5639d1c62c3729c357f186ca43ef32a73
+ sha512sums = 99924737fc91a2634cf301a4a1d5b4f2885f813ef80988af5a537d34f2a893f8f7efd5d30b30ae0b70de6a717fa6d239af4253c299a898641c8215491d5ffc93
+ sha512sums = 72b523346ebe40b603245eeeada75002d1889c32f9d738c18d556a710f5cdb97e393317957097c14dd06a3d099b1183a443b072a13c6b43e7a02202e19a33e7d
+ sha512sums = 4d392dbe03b0e3822a87b2a45de57383957d68f0512e201d3a1e3f44362594fec9e4e8031c422653472218fa23a8ffb6189cd6c8beb7e8ad4c7056b6ab1bcf36
+ source_x86_64 = https://github.com/liberodark/Spiral-Knights/releases/download/1.0.0/spiral.tar.gz
+ sha512sums_x86_64 = 818b8f4ff61b2cbd98ffcd9962771fd383860285d31f54e6b057c3244e056ac986e930324c0e0afe924017658badfdde423062e291161b79803811ef226e832e
+
+pkgname = spiral-knights-steam
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b4a7427ecf52
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/spiral.tar.gz
+/*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b84a4b9d314
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# Maintainer: Steffo <me@steffo.eu>
+# Contributor: liberodark
+
+# Sources used:
+# The original spiral-knights AUR package <https://aur.archlinux.org/packages/spiral-knights/>
+# "Tutorial: How to play Spiral Knights natively on Linux with your Steam account." on r/spiral_knights <https://www.reddit.com/r/spiral_knights/comments/bxby51/tutorial_how_to_play_spiral_knights_natively_on/>
+# "Improve In-Game Performance" guide on Steam <https://steamcommunity.com/sharedfiles/filedetails/?id=1847575647>
+
+# Package information
+pkgname="spiral-knights-steam"
+pkgver=1
+pkgrel=1
+pkgdesc="Spiral Knights Linux client with Steam support"
+arch=("x86_64")
+url="https://store.steampowered.com/app/99900/Spiral_Knights/"
+license=("unknown")
+
+# Dependencies
+depends=(
+ "xdg-utils"
+ "bin32-jre"
+ "steam"
+)
+conflicts=(
+
+)
+
+# Source files
+source_x86_64=(
+ "https://github.com/liberodark/Spiral-Knights/releases/download/1.0.0/spiral.tar.gz"
+)
+source=(
+ # Desktop files
+ "spiral-knights.desktop"
+ "spiral-knights.png"
+ # Steam files
+ "steam_appid.txt"
+ "libsteam_api.so"
+ # Optimization files
+ "extra.txt"
+ # Compatibility files
+ "spiral32"
+)
+
+# Source files checksums
+sha512sums=(
+ # spiral-knights.desktop
+ "b45f60b9a257d0a1aa4593bdb73b9454b467eef6f588225d5d7188be5a06db2254ba61b6e4ef8f7f61f65dc5949f9c2836623bdce905204b9b93d0e253395248"
+ # spiral-knights.png
+ "08d5165d510755ea84ebe189803dbf66e50efd0c5b35d92b48a164f593544bce85b2852e24a41d218c733116e93994e315cafa677b8dc62d2d163a35687c52d8"
+ # steam_appid.txt
+ "35b91557cb0c4521833bb181ad344e64364e524597d91c0533df4c974254039ca6f63d45936c75fdc3383d91b901fab5639d1c62c3729c357f186ca43ef32a73"
+ # libsteam_api.so
+ "99924737fc91a2634cf301a4a1d5b4f2885f813ef80988af5a537d34f2a893f8f7efd5d30b30ae0b70de6a717fa6d239af4253c299a898641c8215491d5ffc93"
+ # extra.txt
+ "72b523346ebe40b603245eeeada75002d1889c32f9d738c18d556a710f5cdb97e393317957097c14dd06a3d099b1183a443b072a13c6b43e7a02202e19a33e7d"
+ # spiral32
+ "4d392dbe03b0e3822a87b2a45de57383957d68f0512e201d3a1e3f44362594fec9e4e8031c422653472218fa23a8ffb6189cd6c8beb7e8ad4c7056b6ab1bcf36"
+)
+sha512sums_x86_64=(
+ '818b8f4ff61b2cbd98ffcd9962771fd383860285d31f54e6b057c3244e056ac986e930324c0e0afe924017658badfdde423062e291161b79803811ef226e832e'
+)
+
+package() {
+ # Enter the source directory
+ cd $srcdir
+ # Extract the sources tar
+ tar --extract -f spiral.tar.gz
+ # Create the /opt/spiral-knights-steam directory and optionally parent directories
+ mkdir --parents "$pkgdir/opt/spiral-knights-steam"
+ # Create the /opt/spiral-knights-steam/native directory
+ mkdir "$pkgdir/opt/spiral-knights-steam/native"
+ # Copy the contents of the source tar to the installation directory
+ cp -r "spiral/." "$pkgdir/opt/spiral-knights-steam/"
+ # Copy the client modifications to the installation directory
+ cp "$srcdir/spiral32" "$pkgdir/opt/spiral-knights-steam/spiral32"
+ cp "$srcdir/steam_appid.txt" "$pkgdir/opt/spiral-knights-steam/steam_appid.txt"
+ cp "$srcdir/libsteam_api.so" "$pkgdir/opt/spiral-knights-steam/native/libsteam_api.so" # This goes in the native/ directory
+ cp "$srcdir/extra.txt" "$pkgdir/opt/spiral-knights-steam/extra.txt"
+ # Change permissions for the spiral-knights-steam directory so that the installer will be able to update itself
+ chmod 667 -R "$pkgdir/opt/spiral-knights-steam" # FIXME: seems like a security risk, but I don't currently have the knowledge to fix it
+ # Install the .desktop files
+ install -D --mode=644 "$srcdir/spiral-knights.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -D --mode=644 "$srcdir/spiral-knights.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..9c3ce6ea41bc
--- /dev/null
+++ b/README.md
@@ -0,0 +1,10 @@
+# `spiral-knights-steam`
+
+Patched Spiral Knights for better performance and steam support for Arch Linux
+
+## Sources
+
+- ["Tutorial: How to play Spiral Knights natively on Linux with your Steam account." on r/spiral_knights](https://www.reddit.com/r/spiral_knights/comments/bxby51/tutorial_how_to_play_spiral_knights_natively_on/)
+- ["Improve In-Game Performance" guide on Steam](https://steamcommunity.com/sharedfiles/filedetails/?id=1847575647)
+- [The original `spiral-knights` AUR package](https://aur.archlinux.org/packages/spiral-knights/)
+
diff --git a/extra.txt b/extra.txt
new file mode 100644
index 000000000000..44f4b2595a97
--- /dev/null
+++ b/extra.txt
@@ -0,0 +1,7 @@
+-XX:+UseStringDeduplication
+-XX:+DisableExplicitGC
+-Xmx2G
+-Xms2G
+-XX:+UseParallelGC
+-XX:+UseParallelOldGC
+
diff --git a/libsteam_api.so b/libsteam_api.so
new file mode 100755
index 000000000000..fa160d5e4302
--- /dev/null
+++ b/libsteam_api.so
Binary files differ
diff --git a/spiral-knights.desktop b/spiral-knights.desktop
new file mode 100644
index 000000000000..7233e8bb8056
--- /dev/null
+++ b/spiral-knights.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Spiral Knights
+Exec=/opt/spiral-knights-steam/spiral32
+Icon=spiral-knights.png
+Terminal=false
+MultipleArgs=false
+Type=Application
+Categories=Application;
diff --git a/spiral-knights.png b/spiral-knights.png
new file mode 100644
index 000000000000..893b622b8e0d
--- /dev/null
+++ b/spiral-knights.png
Binary files differ
diff --git a/spiral32 b/spiral32
new file mode 100755
index 000000000000..494dced69d8a
--- /dev/null
+++ b/spiral32
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $Id: projectx 5338 2009-10-22 21:55:03Z dhoover $
+#
+# Runs the Spiral Knights game updater/launcher.
+
+INSTDIR=`dirname $0`
+
+echo "Using INSTDIR=$INSTDIR"
+
+# do our best to locate the appropriate version of Java
+# JAVA=java
+# if [ -x $INSTDIR/java/bin/java ]; then
+# JAVA=$INSTDIR/java/bin/java
+# elif [ -x $JAVA_HOME/bin/java ]; then
+# JAVA=$JAVA_HOME/bin/java
+# fi
+
+# use custom java32
+JAVA="java32"
+
+echo "Using JAVA=$JAVA"
+
+# run the updater/launcher
+$JAVA $* -jar $INSTDIR/getdown-pro.jar $INSTDIR
+
+echo "Finished"
+
diff --git a/steam_appid.txt b/steam_appid.txt
new file mode 100644
index 000000000000..c7efbe4dc316
--- /dev/null
+++ b/steam_appid.txt
@@ -0,0 +1 @@
+99900