summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Hedayioglu2018-05-16 20:19:15 +0100
committerFabio Hedayioglu2018-05-16 20:19:15 +0100
commit45e10601c4d0f28e4e01e8bb29568084494a6d34 (patch)
tree0d486dbf01d3d24eceeba0c95a27f499ede35ae6
downloadaur-splinterpy-git.tar.gz
initial version commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a95ef246185
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = splinterpy-git
+ pkgdesc = Library for multivariate function approximation with splines (B-spline, P-spline, and more) with interfaces to C++, C, Python and MATLAB - Git build
+ pkgver = v3.0.r9.gbce2916
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/bgrimstad/splinter/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = cmake
+ makedepends = boost
+ makedepends = git
+ makedepends = clang
+ options = !emptydirs
+ source = git+https://github.com/bgrimstad/splinter.git
+ sha512sums = SKIP
+
+pkgname = splinterpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c87672e9348d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Fabio Heday <fheday@gmail.com>
+
+pkgname=splinterpy-git
+pkgver=v3.0.r9.gbce2916
+pkgrel=1
+epoch=1
+license=('APACHE')
+pkgdesc="Library for multivariate function approximation with splines (B-spline, P-spline, and more) with interfaces to C++, C, Python and MATLAB - Git build"
+arch=(i686 x86_64)
+url="https://github.com/bgrimstad/splinter/"
+makedepends=(cmake boost git clang)
+source=('git+https://github.com/bgrimstad/splinter.git')
+sha512sums=('SKIP')
+options=(!emptydirs)
+
+pkgver() {
+ cd splinter
+ git describe --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ export CXX=$(which clang++)
+ cd splinter
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX="${pkgdir}"/ -DLIBRARY_INSTALL_DIRECTORY="${pkgdir}"/usr/lib/
+ make -j
+ cd ../python
+ python setup.py build
+# ./scripts/build_release.sh
+}
+
+package() {
+ cd splinter/build
+ make install
+ cd ../python
+ python setup.py install --root="$pkgdir"/ --optimize=1 --prefix=/usr/
+#--skip-build
+# make DESTDIR="${pkgdir}/" install
+}
+