summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Whetter2015-06-08 11:27:33 +0100
committerAshley Whetter2015-06-08 11:27:33 +0100
commitdf0b5cc1eafbfaae0f949bff51e430b2949e4aa0 (patch)
tree1081a19c19d8840bff4bfe908af48e5aadb8986e
downloadaur-df0b5cc1eafbfaae0f949bff51e430b2949e4aa0.tar.gz
Initial import
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD51
-rw-r--r--spotify2
-rw-r--r--spotify.changelog235
-rw-r--r--spotify.install13
-rwxr-xr-xspotify.protocol11
6 files changed, 350 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..257685cd2ee8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+# Generated by makepkg 4.2.1
+# Fri May 22 11:29:51 UTC 2015
+pkgbase = spotify
+ pkgdesc = A proprietary peer-to-peer music streaming service
+ pkgver = 0.9.17.8
+ pkgrel = 1
+ url = http://www.spotify.com
+ install = spotify.install
+ changelog = spotify.changelog
+ arch = x86_64
+ license = custom:"Copyright (c) 2006-2010 Spotify Ltd"
+ depends = alsa-lib>=1.0.14
+ depends = glibc>=2.6
+ depends = libxss>=1.2.0
+ depends = qt4>=4.5.0
+ depends = openssl
+ depends = nspr>=4.0
+ depends = nspr<5.0
+ depends = gconf
+ depends = nss
+ depends = dbus
+ depends = systemd
+ depends = libgcrypt15
+ depends = gtk2
+ optdepends = desktop-file-utils: Adds URI support to compatible desktop environments
+ optdepends = ffmpeg-compat: Adds support for playback of local files
+ optdepends = libnotify: Adds desktop notifications
+ conflicts = spotify-beta
+ options = !strip
+ source = http://repository.spotify.com/pool/non-free/s/spotify/spotify-client-0.9.17_0.9.17.8.gd06432d.31-1_amd64.deb
+ source = spotify
+ source = spotify.protocol
+ md5sums = 69a320368ded33cfcc4e3bb4cc71575c
+ md5sums = d443873ef440a6b59d2e3deef64ab74b
+ md5sums = ef25ddc5b6bf8fe1a0d64cbd79e1f7b4
+
+pkgname = spotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0bd6d26e8d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Ashley Whetter <(firstname) @ awhetter.co.uk>
+# Contributor: Eothred <yngve.levinsen@gmail.com>
+
+pkgname=spotify
+pkgver=0.9.17.8
+_anotherpkgver=.gd06432d.31-1
+pkgrel=1
+pkgdesc="A proprietary music streaming service"
+arch=('x86_64')
+license=('custom:"Copyright (c) 2006-2010 Spotify Ltd"')
+install=spotify.install
+url="http://www.spotify.com"
+changelog='spotify.changelog'
+options=('!strip')
+conflicts=('spotify-beta')
+
+source=("http://repository.spotify.com/pool/non-free/s/${pkgname}/${pkgname}-client-0.9.17_${pkgver}${_anotherpkgver}_amd64.deb"
+'spotify'
+'spotify.protocol'
+)
+md5sums=('69a320368ded33cfcc4e3bb4cc71575c'
+'d443873ef440a6b59d2e3deef64ab74b'
+'ef25ddc5b6bf8fe1a0d64cbd79e1f7b4')
+
+depends=("alsa-lib>=1.0.14" "glibc>=2.6" "libxss>=1.2.0" "qt4>=4.5.0" "openssl" "nspr>=4.0" "nspr<5.0" "gconf" "nss" "dbus" "systemd" "libgcrypt15" "gtk2")
+optdepends=('desktop-file-utils: Adds URI support to compatible desktop environments'
+ 'ffmpeg-compat: Adds support for playback of local files'
+ 'libnotify: Adds desktop notifications'
+ )
+
+package() {
+ cd "${srcdir}"
+
+ tar -xJf data.tar.xz -C "${pkgdir}"
+
+ install -d "${pkgdir}/usr/share/"
+ mv "${pkgdir}/opt/spotify" "${pkgdir}/usr/share/"
+ rm -r "${pkgdir}/opt"
+
+ # Bin Script
+ install -Dm755 "${srcdir}/spotify" "${pkgdir}/usr/bin/spotify"
+
+ # Copy license
+ install -Dm644 "${pkgdir}/usr/share/doc/${pkgname}-client-0.9.17/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
+
+ # Copy protocol file if KDE is installed
+ if [ -f /usr/bin/startkde ]; then
+ echo "Installing with KDE support"
+ install -Dm644 "${srcdir}/spotify.protocol" "${pkgdir}/usr/share/kde4/services/spotify.protocol"
+ fi
+}
diff --git a/spotify b/spotify
new file mode 100644
index 000000000000..26590dd7f838
--- /dev/null
+++ b/spotify
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/share/spotify/spotify-client/spotify "$@"
diff --git a/spotify.changelog b/spotify.changelog
new file mode 100644
index 000000000000..6432338b636b
--- /dev/null
+++ b/spotify.changelog
@@ -0,0 +1,235 @@
+22nd May 2015 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * 0.9.17.8
+ Updated spotify version (.gd06432d.31-1)
+ Removed 32-bit support
+ Updated dependencies
+
+24th March 2015 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * 0.9.17.1
+ Updated spotify version (.g9b85d43.7-1)
+
+5th March 2015 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * PKGBUILD
+ Removed gtk2 libraries. gtk2 2.24.27 fixed the segfaulting problem
+
+27th February 2015 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * PKGBUILD
+ Added gtk2 2.24.24 libraries to stop segfaulting from gtk2 version 2.24.26
+
+22nd July 2014 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * 0.9.11.27
+ Updated spotify version (.g2b1a638.81-1)
+
+3rd July 2014 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * 0.9.11.26
+ Updated spotify version (.g995ec04.78-1)
+
+20th May 2014 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * 0.9.10.17
+ Updated spotify version (.g4129e1c.78-1)
+
+ * PKGBUILD
+ Numerous libraries no longer need to be symlinked
+
+10th October 2013 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * 0.9.4.183
+ Updated spotify version (.g644e24e.428-1)
+ Added dbus as a dependency
+ Added systemd as a dependency
+ Removed openssl098 symlinks
+ Removed ffmpeg-spotify as an optional dependency
+
+18th June 2013 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * 0.9.1.55
+ Updated spotify version (.gbdd3b79.203-1)
+
+4th May 2013 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * 0.9.0.133
+ Updated spotify version (.gd18ed58.259-1)
+
+21st April 2013 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * PKGBUILD
+ Removed bundled ubuntu libraries
+
+16th April 2013 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * PKGBUILD
+ Removed libpng12 dependencies
+
+1st March 2013 (GMT) Gadget3000 <gadget3000 at msn dot com>
+ * PKGBUILD
+ Removed qt and openssl098 dependencies
+ Stopped bundling qtwebkit libraries
+ Started bundling ubuntu libssl098 libraries
+
+3rd January 2013 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * 0.8.8.309
+ Updated spotify version (.g76c21dc.239-1)
+
+12th May 2012 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * 0.8.3.278
+ Updated spotify version (.g21c7566.632-1)
+
+14th March 2012 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD
+ Added some ubuntu libraries and symlinks into the package to stop
+ the need for LD_LIBRARY_PATH
+
+27th March 2012 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * 0.8.2.639
+ Updated spotify version (.g79d339d.504-1)
+
+ * PKGBUILD
+ Added libpng12 as a dependency
+ Added gconf as a dependency
+
+24th March 2012 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * 0.8.2.637
+ Updated spotify version (.g252b980.486-1)
+
+ * spotify.desktop
+ Removed
+
+ * spotify.png
+ Removed
+
+14th February 2012 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD
+ Replaced openssl dependency with openssl098
+ Removed symlinks to openssl library
+
+27th January 2012 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * 0.6.6.10
+ Updated spotify version (.gbd39032.58-1)
+
+ * PKGBUILD
+ Added desktop-file-utils as an optdepends
+
+ * spotify.desktop
+ Added URI support
+
+ * spotify.install
+ Added to register MimeType for URI support
+
+17th November 2011 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD
+ Removed the need for deb2targz in favour of ar
+
+26th October 2011 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD
+ Fixed a typo
+ Changed desktop icon to any spotify logo on the system
+ Fixed creating symlinks when any openssl package is installed
+
+18th October 2011 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD
+ Removed spotify-gnome-support package
+
+14th October 2011 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * 0.6.2.291 :
+ Updated spotify version (.gcccc1f5.116-1)
+
+23rd September 2011 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * 0.6.1.309 :
+ Updated spotify version (.gb871a7d-1)
+
+ * PKGBUILD :
+ Added openssl as a dependency
+
+ * spotify.changelog :
+ Added this changelog
+
+20th July 2011 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * 0.5.2.84 :
+ Updated spotify version (.g6d797eb-1)
+
+7th June 2011 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated spotify version
+
+24th December 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated spotify version
+
+16th December 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Added libxss as a dependency
+
+28th November 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Replaced pulseaudio in the dependencies with libpulse
+
+11th November 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated spotify version
+
+10th November 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated spotify version
+ Updated dependencies (pulseaudio added)
+
+29th October 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated spotify version
+
+8th September 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated dependencies
+ SPOTIFYGNOMESUPPORT environment variable is no longer required
+
+24th August 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated spotify version
+
+28th July 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated spotify version
+
+27th July 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ More closely follows packaging etiquette at
+ http://wiki.archlinux.org/index.php/Arch_Packaging_Standards
+
+23rd July 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Added AudioVideo category to the .desktop file for KDE users
+ Updated spotify version
+ Added KDE support
+
+15th July 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Updated spotify version
+
+13th July 2010 (GMT) Gadget3000 <gadget3000 at msn dot com>
+
+ * PKGBUILD :
+ Added Eothred's ammendments for adding both architectures and
+ placement of the license file
+ Added an icon file and desktop file
+ Added Gnome support package but requires a higher version of gconf
+ than the official binaries or in the AUR.
diff --git a/spotify.install b/spotify.install
new file mode 100644
index 000000000000..f22bca23bf72
--- /dev/null
+++ b/spotify.install
@@ -0,0 +1,13 @@
+post_install() {
+ cd /usr/share/spotify/spotify-client
+ ./register.sh
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ cd /usr/share/spotify/spotify-client
+ ./unregister.sh
+}
diff --git a/spotify.protocol b/spotify.protocol
new file mode 100755
index 000000000000..423a5fc2e7dc
--- /dev/null
+++ b/spotify.protocol
@@ -0,0 +1,11 @@
+[Protocol]
+exec=/usr/bin/spotify -uri "%u"
+protocol=spotify
+input=none
+output=none
+helper=true
+listing=false
+reading=false
+writing=false
+makedir=false
+deleting=false