summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMageJohn2017-01-12 19:36:46 +0000
committerMageJohn2017-01-12 19:36:46 +0000
commit7b7d598da9a300fb064f27ae89ec1b4f9f433209 (patch)
tree2d60d11dad94b86e2b596cce05c30e5b571f7a0a
parentf8c6dcc6b94ae6867592bfb2f9f3e1746297edfd (diff)
downloadaur-7b7d598da9a300fb064f27ae89ec1b4f9f433209.tar.gz
Add the branch to the git source line
`makepkg` can download a specific branch of a git repository, without having to manually do a checkout in the `prepare()` function.
-rw-r--r--PKGBUILD4
1 files changed, 1 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36d86882d3ab..43d757536a66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ depends=('spotify')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+$url.git"
+source=("git+$url.git#branch=dns-block"
"${pkgname%-git}"
"Spotify (dns-block).desktop")
sha512sums=('SKIP'
@@ -20,13 +20,11 @@ sha512sums=('SKIP'
pkgver() {
cd "${url##*/}"
- git checkout -q dns-block
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "${url##*/}"
- git checkout -q dns-block
}
build() {