summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-04-18 18:18:06 +0200
committerwillemw122016-04-18 18:18:06 +0200
commit259f546cf3e017a12a2c9c8b98b97a8783c83105 (patch)
tree7debb1dbf02412f9f30ad53d29744170d706487d
parent0a2db1aa2c9df1d7648cfe7518e57c5d65ac9d73 (diff)
downloadaur-259f546cf3e017a12a2c9c8b98b97a8783c83105.tar.gz
Move 'jedi' and 'rope' from 'optdepends' to 'depends'
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77845ab0f723..6917c55bbd5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,5 @@
-# Generated by mksrcinfo v8
-# Sat Jan 30 07:55:54 UTC 2016
pkgbase = spyder-git
- pkgver = 3.0.0b2.r130.gb269751
+ pkgver = 3.0.0b2.r486.geb840fe
pkgrel = 1
url = https://github.com/spyder-ide/spyder
install = spyder-git.install
@@ -19,6 +17,8 @@ pkgname = spyder-git
pkgdesc = Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 2 version)
depends = python2-pyqt5
depends = ipython2-notebook
+ depends = python2-rope
+ depends = python2-jedi
depends = python2-pyflakes
depends = python2-sphinx
depends = python2-pygments
@@ -31,8 +31,6 @@ pkgname = spyder-git
depends = gtk-update-icon-cache
optdepends = python2-pyqt4: Qt-Python bindings
optdepends = python2-pyside: Qt-Python bindings
- optdepends = python2-rope: editor code completion, calltips and go-to-definition
- optdepends = python2-jedi: editor code completion, calltips and go-to-definition
optdepends = python2-matplotlib: 2D/3D plotting
optdepends = python2-pandas: DataFrame and Series support
optdepends = python2-numpy: N-dimensional arrays
@@ -46,6 +44,8 @@ pkgname = spyder3-git
pkgdesc = Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 3 version)
depends = python-pyqt5
depends = jupyter
+ depends = python-rope
+ depends = python-jedi
depends = python-pyflakes
depends = python-sphinx
depends = python-pygments
@@ -58,8 +58,6 @@ pkgname = spyder3-git
depends = gtk-update-icon-cache
optdepends = python-pyqt4: Qt-Python bindings
optdepends = python-pyside: Qt-Python bindings
- optdepends = python-rope: editor code completion, calltips and go-to-definition
- optdepends = python-jedi: editor code completion, calltips and go-to-definition
optdepends = python-matplotlib: 2D/3D plotting
optdepends = python-pandas: DataFrame and Series support
optdepends = python-numpy: N-dimensional arrays
diff --git a/PKGBUILD b/PKGBUILD
index 38eb8b22b3ac..36e465e4db3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname2=spyder
_pkgname3=spyder3
pkgbase=$_pkgname2-git
pkgname=($_pkgname2-git $_pkgname3-git)
-pkgver=3.0.0b2.r130.gb269751
+pkgver=3.0.0b2.r486.geb840fe
pkgrel=1
arch=('any')
url="https://github.com/spyder-ide/spyder"
@@ -42,6 +42,8 @@ package_spyder-git() {
# 'icu'
depends=('python2-pyqt5'
'ipython2-notebook'
+ 'python2-rope'
+ 'python2-jedi'
'python2-pyflakes'
'python2-sphinx'
'python2-pygments'
@@ -49,14 +51,11 @@ package_spyder-git() {
'python2-pep8'
'python2-psutil'
'python2-qtawesome'
-
'python2-pyzmq'
'desktop-file-utils'
'gtk-update-icon-cache')
optdepends=('python2-pyqt4: Qt-Python bindings'
'python2-pyside: Qt-Python bindings'
- 'python2-rope: editor code completion, calltips and go-to-definition'
- 'python2-jedi: editor code completion, calltips and go-to-definition'
'python2-matplotlib: 2D/3D plotting'
'python2-pandas: DataFrame and Series support'
'python2-numpy: N-dimensional arrays'
@@ -82,6 +81,8 @@ package_spyder3-git() {
# 'icu'
depends=('python-pyqt5'
'jupyter'
+ 'python-rope'
+ 'python-jedi'
'python-pyflakes'
'python-sphinx'
'python-pygments'
@@ -89,14 +90,11 @@ package_spyder3-git() {
'pep8'
'python-psutil'
'python-qtawesome'
-
'python-pyzmq'
'desktop-file-utils'
'gtk-update-icon-cache')
optdepends=('python-pyqt4: Qt-Python bindings'
'python-pyside: Qt-Python bindings'
- 'python-rope: editor code completion, calltips and go-to-definition'
- 'python-jedi: editor code completion, calltips and go-to-definition'
'python-matplotlib: 2D/3D plotting'
'python-pandas: DataFrame and Series support'
'python-numpy: N-dimensional arrays'