summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-08-25 16:24:31 +0200
committerwillemw122015-08-25 16:24:31 +0200
commit5964e54a7b072bfec2116721e2d7669ebcc3cd68 (patch)
treef03872ef88ce02356421a8f9a997fc08a2277ec4
parent667236b6e396a9e60611e346898a8a994784c8fe (diff)
downloadaur-5964e54a7b072bfec2116721e2d7669ebcc3cd68.tar.gz
Remove most of the "Python to Python2" patches
-rw-r--r--PKGBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9298d44dfac..46f4fedcdf59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname2=spyder
_pkgname3=spyder3
pkgbase=$_pkgname2-git
pkgname=($_pkgname2-git $_pkgname3-git)
-pkgver=2.3.5.2.r1957.gcda8dd6
+pkgver=3.0.0b1.r134.g2e7699b
pkgrel=1
arch=('any')
url="https://github.com/spyder-ide/spyder"
@@ -25,17 +25,9 @@ prepare() {
rm -rf $_pkgname3
cp -a $_pkgname2 $_pkgname3
- cd $_pkgname2
-
- # Patch PYLINT_PATH = programs.find_program('pylint')
- sed -i "s/find_program('pylint'/find_program('pylint2'/" spyderplugins/widgets/pylintgui.py
- # Patch process = subprocess.Popen(['pylint', '--version'],
- sed -i "s/subprocess.Popen(\['pylint'/subprocess.Popen(\['pylint2'/" spyderplugins/widgets/pylintgui.py
- # Patch match = re.match('(pylint|pylint-script.py) ([0-9\.]*)', lines[0])
- sed -i "s/re.match('(pylint|pylint-script.py/re.match('(pylint2|pylint2-script.py/" spyderplugins/widgets/pylintgui.py
-
# Patch Python/Python2
- sed -i 's|#![ ]*/usr/bin/env python[ \t\r]*$|#!/usr/bin/env python2|' spyderlib/userconfig.py spyderlib/utils/external/pickleshare.py
+ cd $_pkgname2
+ sed -i 's|#![ ]*/usr/bin/env python[ \t\r]*$|#!/usr/bin/env python2|' spyderlib/utils/external/pickleshare.py
}
build() {