summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122016-01-25 20:32:26 +0100
committerwillemw122016-01-25 20:32:26 +0100
commit6c040fd88c3156791f2de920bbb5b844e67e2192 (patch)
tree1ae4407f01d2def9a96f6ba2b2f0b5eef2bc0b0e
parentdf6f77fec7bafa03016c3997a03ec060b0151a91 (diff)
downloadaur-6c040fd88c3156791f2de920bbb5b844e67e2192.tar.gz
Change default from qt4 to qt5
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD36
2 files changed, 28 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb59a85ce749..717331754994 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Sat Jan 9 06:08:52 UTC 2016
+# Mon Jan 25 19:31:56 UTC 2016
pkgbase = spyder-git
- pkgver = 3.0.0b2.r82.g66b92f8
+ pkgver = 3.0.0b2.r119.g7bae783
pkgrel = 1
url = https://github.com/spyder-ide/spyder
install = spyder-git.install
@@ -18,7 +18,7 @@ pkgbase = spyder-git
pkgname = spyder-git
pkgdesc = Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 2 version)
depends = ipython2-notebook
- depends = python2-pyqt4
+ depends = python2-pyqt5
depends = python2-pyflakes
depends = python2-sphinx
depends = python2-pygments
@@ -29,7 +29,7 @@ pkgname = spyder-git
depends = python2-pyzmq
depends = desktop-file-utils
depends = gtk-update-icon-cache
- optdepends = python2-pyqt5: Qt-Python bindings
+ optdepends = python2-pyqt4: Qt-Python bindings
optdepends = python2-pyside: Qt-Python bindings
optdepends = python2-rope: editor code completion, calltips and go-to-definition
optdepends = python2-jedi: editor code completion, calltips and go-to-definition
@@ -45,18 +45,19 @@ pkgname = spyder-git
pkgname = spyder3-git
pkgdesc = Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 3 version)
depends = ipython-notebook
- depends = python-pyqt4
+ depends = python-pyqt5
depends = python-pyflakes
depends = python-sphinx
depends = python-pygments
depends = python-pylint
depends = pep8
depends = python-psutil
+ depends = jupyter
depends = python-qtawesome
depends = python-pyzmq
depends = desktop-file-utils
depends = gtk-update-icon-cache
- optdepends = python-pyqt5: Qt-Python bindings
+ optdepends = python-pyqt4: Qt-Python bindings
optdepends = python-pyside: Qt-Python bindings
optdepends = python-rope: editor code completion, calltips and go-to-definition
optdepends = python-jedi: editor code completion, calltips and go-to-definition
diff --git a/PKGBUILD b/PKGBUILD
index 00dcd14b3cdf..b578483258ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname2=spyder
_pkgname3=spyder3
pkgbase=$_pkgname2-git
pkgname=($_pkgname2-git $_pkgname3-git)
-pkgver=3.0.0b2.r82.g66b92f8
+pkgver=3.0.0b2.r119.g7bae783
pkgrel=1
arch=('any')
url="https://github.com/spyder-ide/spyder"
@@ -36,9 +36,11 @@ build() {
package_spyder-git() {
pkgdesc="Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 2 version)"
- #'icu'
+ # 'icu'
+ # 'jupyter' does not contain a Python 2 of Nbconvert
+ # 'ipython2' ('ipython2-notebook') contains Pickleshare
depends=('ipython2-notebook'
- 'python2-pyqt4'
+ 'python2-pyqt5'
'python2-pyflakes'
'python2-sphinx'
'python2-pygments'
@@ -50,9 +52,9 @@ package_spyder-git() {
'python2-pyzmq'
'desktop-file-utils'
'gtk-update-icon-cache')
- #'ipython2<4.0: enhanced Python interpreter'
- #'ipython2-notebook>=4.0: enhanced Python interpreter (qtconsole)'
- optdepends=('python2-pyqt5: Qt-Python bindings'
+ # 'ipython2<4.0: enhanced Python interpreter'
+ # 'ipython2-notebook>=4.0: enhanced Python interpreter (qtconsole)'
+ optdepends=('python2-pyqt4: Qt-Python bindings'
'python2-pyside: Qt-Python bindings'
'python2-rope: editor code completion, calltips and go-to-definition'
'python2-jedi: editor code completion, calltips and go-to-definition'
@@ -60,8 +62,8 @@ package_spyder-git() {
'python2-pandas: DataFrame and Series support'
'python2-numpy: N-dimensional arrays'
'python2-sympy: symbolic mathematics'
-
'python2-scipy: signal/image processing'
+
'python2-h5py: HDF5 support')
provides=($_pkgname2)
conflicts=($_pkgname2)
@@ -71,28 +73,32 @@ package_spyder-git() {
# Install a scalable icon for the spyder.desktop file
install -Dm644 spyderlib/images/spyder.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/spyder.svg"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname2/LICENSE"
- rm "$pkgdir/usr/bin/spyder_win_post_install.py"
+ rm -f "$pkgdir/usr/bin/spyder_win_post_install.py"
}
package_spyder3-git() {
pkgdesc="Scientific PYthon Development EnviRonment providing MATLAB-like features (Python 3 version)"
- #'icu'
+ # 'icu'
+ # 'ipython' ('ipython-notebook') contains Pickleshare
+ # 'jupyter' contains Nbconvert
depends=('ipython-notebook'
- 'python-pyqt4'
+ 'python-pyqt5'
'python-pyflakes'
'python-sphinx'
'python-pygments'
'python-pylint'
'pep8'
'python-psutil'
+ 'jupyter'
'python-qtawesome'
'python-pyzmq'
'desktop-file-utils'
'gtk-update-icon-cache')
- #'ipython<4.0: enhanced Python interpreter'
- #'ipython-notebook>=4.0: enhanced Python interpreter (qtconsole)'
- optdepends=('python-pyqt5: Qt-Python bindings'
+ # 'ipython<4.0: enhanced Python interpreter'
+ # 'ipython-notebook>=4.0: enhanced Python interpreter (qtconsole)'
+ # 'jupyter: nbconvert - manipulation of notebooks in the Editor'
+ optdepends=('python-pyqt4: Qt-Python bindings'
'python-pyside: Qt-Python bindings'
'python-rope: editor code completion, calltips and go-to-definition'
'python-jedi: editor code completion, calltips and go-to-definition'
@@ -100,8 +106,8 @@ package_spyder3-git() {
'python-pandas: DataFrame and Series support'
'python-numpy: N-dimensional arrays'
'python-sympy: symbolic mathematics'
-
'python-scipy: signal/image processing'
+
'python-h5py: HDF5 support')
provides=($_pkgname3)
conflicts=($_pkgname3)
@@ -111,6 +117,6 @@ package_spyder3-git() {
# Install a scalable icon for the spyder3.desktop file
install -Dm644 spyderlib/images/spyder.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/spyder3.svg"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname3/LICENSE"
- rm "$pkgdir/usr/bin/spyder_win_post_install.py"
+ rm -f "$pkgdir/usr/bin/spyder_win_post_install.py"
}