summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-07-10 16:39:13 +0200
committerwillemw122021-07-10 16:42:47 +0200
commit7c267fe6b3c42dded2f2e68f5a70b4c7597f32dc (patch)
tree7f5ddd40cdef606f627d668a06c374cd74ef804e
parent55a4c1db45c17972bcc191063ef3f078bae630ad (diff)
downloadaur-7c267fe6b3c42dded2f2e68f5a70b4c7597f32dc.tar.gz
Change pkgname to spyder-git
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 017d547f9a32..2bd0eb4737a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spyder-git
- pkgdesc = The Scientific Python Development Environment (Python 3 version)
- pkgver = 5.0.0a1.r2.g36ff0882c
+ pkgdesc = The Scientific Python Development Environment
+ pkgver = 5.0.5.r360.gd829e6db6
pkgrel = 1
url = https://www.spyder-ide.org/
arch = any
@@ -52,10 +52,11 @@ pkgbase = spyder-git
optdepends = python-scipy: signal/image processing
optdepends = python-sympy: symbolic mathematics
optdepends = python-h5py: HDF5 support
- provides = spyder3
- conflicts = spyder3
- source = spyder3-git::git+https://github.com/spyder-ide/spyder.git
+ provides = spyder
+ conflicts = spyder
+ conflicts = spyder3-git
+ replaces = spyder3-git
+ source = spyder-git::git+https://github.com/spyder-ide/spyder.git
md5sums = SKIP
-pkgname = spyder3-git
-
+pkgname = spyder-git
diff --git a/PKGBUILD b/PKGBUILD
index 4cc250fc97df..b2137a4a3263 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer: willemw <willemw12@gmail.com>
-pkgbase=spyder-git
-pkgname=spyder3-git
-pkgver=5.0.0a1.r2.g36ff0882c
+pkgname=spyder-git
+pkgver=5.0.5.r360.gd829e6db6
pkgrel=1
-pkgdesc="The Scientific Python Development Environment (Python 3 version)"
+pkgdesc="The Scientific Python Development Environment"
arch=('any')
url="https://www.spyder-ide.org/"
license=('MIT')
@@ -58,14 +57,15 @@ optdepends=('cython: run Cython files'
'python-h5py: HDF5 support')
provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" 'spyder3-git')
+replaces=('spyder3-git')
source=($pkgname::git+https://github.com/spyder-ide/spyder.git)
md5sums=('SKIP')
pkgver() {
cd $pkgname
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+}
prepare() {
find $pkgname -type f -iname \*.py -exec sed -i -e 's|"pep8"|"pycodestyle"|g' -e "s|'pep8'|'pycodestyle'|g" '{}' \;
@@ -81,7 +81,7 @@ package() {
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE.txt"
+ install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
# Install a scalable icon for the spyder3.desktop file
install -Dm644 spyder/images/spyder.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/spyder3.svg"