summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2015-06-20 23:01:23 -0400
committerYaohan Chen2015-06-20 23:01:23 -0400
commitf3a997252a6cb5f38632d3b77d097665bcaaf5bb (patch)
tree7be1fc47939bbffb061f5f30e0a0ba07c5b5a7df
downloadaur-sqtop-git.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bedfdb3cc3c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = sqtop-git
+ pkgdesc = sqtop is a console applicaton to display information about currently active client connections for a Squid proxy in a convenient way.
+ pkgver = 40.gdc33d36
+ pkgrel = 1
+ url = http://code.google.com/p/sqtop/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = squid
+ depends = squid
+ provides = sqtop
+ conflicts = sqtop
+ source = git+https://code.google.com/p/sqtop/
+ sha256sums = SKIP
+
+pkgname = sqtop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9d2b3691617
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Author & maintainer: Bohdan Turkynewych <tb0hdan@gmail.com>
+# Contributor: Yaohan Chen <yaohan.chen@gmail.com>
+
+pkgname=sqtop-git
+_distname=sqtop
+pkgver=40.gdc33d36
+pkgrel=1
+pkgdesc="sqtop is a console applicaton to display information about currently active client connections for a Squid proxy in a convenient way."
+arch=(i686 x86_64)
+url="http://code.google.com/p/sqtop/"
+depends=('squid')
+makedepends=('squid')
+provides=('sqtop')
+conflicts=('sqtop')
+
+license=('GPL')
+source=(git+https://code.google.com/p/sqtop/)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/sqtop
+ echo $(git rev-list --count HEAD).g$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd ${srcdir}/sqtop
+ ./configure --prefix=/usr --sysconfdir=/etc/
+ make
+}
+
+package() {
+ cd ${srcdir}/sqtop
+ make DESTDIR=${pkgdir} install
+}