summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblue2022-04-02 15:59:23 +0300
committerblue2022-04-02 15:59:23 +0300
commit2b40dab6ca370cf7cd96544ba7e3be0f55f066ac (patch)
tree60f291fd3e1d554f4fed3f84f1fe94c1d45dde79
parent399a9ae1c8d9d8f057bc02d935b9531bf4eb1da2 (diff)
downloadaur-2b40dab6ca370cf7cd96544ba7e3be0f55f066ac.tar.gz
0.2.1: basic settings and message correction
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d093f48b01c..b7b8bd67b1c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = squawk
pkgdesc = An XMPP desktop messenger, written on pure c++ (qt)
- pkgver = 0.2.0
- pkgrel = 2
+ pkgver = 0.2.1
+ pkgrel = 1
url = https://git.macaw.me/blue/squawk
arch = i686
arch = x86_64
@@ -9,14 +9,16 @@ pkgbase = squawk
makedepends = cmake>=3.3
makedepends = imagemagick
makedepends = qt5-tools
+ makedepends = boost
depends = hicolor-icon-theme
depends = desktop-file-utils
depends = lmdb
- depends = qxmpp
- depends = boost
+ depends = qxmpp>=1.1.0
optdepends = kwallet: secure password storage (requires rebuild)
+ optdepends = kconfig: system themes support (requires rebuild)
+ optdepends = kconfigwidgets: system themes support (requires rebuild)
optdepends = kio: better show in folder action (requires rebuild)
- source = squawk-0.2.0.tar.gz::https://git.macaw.me/attachments/6264b2e6-ed0f-4346-a545-54f337284778
- sha256sums = 057d6c4e4a05f29d35727fc045dbec74ccda78382316bd6e124da0614f314901
+ source = squawk-0.2.1.tar.gz::https://git.macaw.me/attachments/0d1b2782-4ac0-4760-86e1-9985b165f95a
+ sha256sums = c00dad1e441601acabb5200dc394f53abfc9876f3902a7dd4ad2fee3232ee84d
pkgname = squawk
diff --git a/PKGBUILD b/PKGBUILD
index 48510d7bd90a..55a1ba32b7a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
# Maintainer: Yury Gubich <blue@macaw.me>
pkgname=squawk
-pkgver=0.2.0
-pkgrel=2
+pkgver=0.2.1
+pkgrel=1
pkgdesc="An XMPP desktop messenger, written on pure c++ (qt)"
arch=('i686' 'x86_64')
url="https://git.macaw.me/blue/squawk"
license=('GPL3')
-depends=('hicolor-icon-theme' 'desktop-file-utils' 'lmdb' 'qxmpp' 'boost')
-makedepends=('cmake>=3.3' 'imagemagick' 'qt5-tools')
-optdepends=('kwallet: secure password storage (requires rebuild)' 'kio: better show in folder action (requires rebuild)')
+depends=('hicolor-icon-theme' 'desktop-file-utils' 'lmdb' 'qxmpp>=1.1.0')
+makedepends=('cmake>=3.3' 'imagemagick' 'qt5-tools' 'boost')
+optdepends=('kwallet: secure password storage (requires rebuild)'
+ 'kconfig: system themes support (requires rebuild)'
+ 'kconfigwidgets: system themes support (requires rebuild)'
+ 'kio: better show in folder action (requires rebuild)')
-source=("$pkgname-$pkgver.tar.gz::https://git.macaw.me/attachments/6264b2e6-ed0f-4346-a545-54f337284778")
-sha256sums=('057d6c4e4a05f29d35727fc045dbec74ccda78382316bd6e124da0614f314901')
+source=("$pkgname-$pkgver.tar.gz::https://git.macaw.me/attachments/0d1b2782-4ac0-4760-86e1-9985b165f95a")
+sha256sums=('c00dad1e441601acabb5200dc394f53abfc9876f3902a7dd4ad2fee3232ee84d')
build() {
cd "$srcdir/squawk"
cmake . -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release
@@ -19,5 +22,5 @@ build() {
}
package() {
cd "$srcdir/squawk"
- DESTDIR="$pkgdir/" cmake --build . --target install
+ DESTDIR="$pkgdir/" cmake --build . --target install
}