summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 20:18:32 +0100
committerBartłomiej Piotrowski2018-01-06 20:18:32 +0100
commitd038c5ed8aeb4d6de65a783b145ad0e0438e5dae (patch)
tree92a46a27d52fd69a886c033790f48f8632bfa3b1
downloadaur-ssh-faker.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--ssh-faker.install31
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce1a6e6197a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ssh-faker
+ pkgdesc = A whitelisting perl script for sshd.
+ pkgver = 1.1
+ pkgrel = 5
+ url = http://www.pkts.ca/ssh-faker.shtml
+ install = ssh-faker.install
+ arch = any
+ license = GPL
+ depends = perl
+ depends = openssh
+ source = https://www.pkts.ca/ssh-faker-1.1.tar.gz
+ sha256sums = 12dd42e0b8ef98031876cc2e054943c9efd68d47ebfbe6abd15e407b76f90486
+
+pkgname = ssh-faker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3089e04a9184
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 195848 2016-11-14 17:52:18Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: FJ <joostef@gmail.com>
+
+pkgname=ssh-faker
+pkgver=1.1
+pkgrel=5
+pkgdesc="A whitelisting perl script for sshd."
+arch=('any')
+license=('GPL')
+url="http://www.pkts.ca/ssh-faker.shtml"
+depends=('perl' 'openssh')
+install=ssh-faker.install
+source=("https://www.pkts.ca/$pkgname-$pkgver.tar.gz")
+sha256sums=('12dd42e0b8ef98031876cc2e054943c9efd68d47ebfbe6abd15e407b76f90486')
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ mkdir -p "$pkgdir"/usr/bin
+ install -m755 ssh-faker "$pkgdir"/usr/bin
+}
diff --git a/ssh-faker.install b/ssh-faker.install
new file mode 100644
index 000000000000..27c9774418b9
--- /dev/null
+++ b/ssh-faker.install
@@ -0,0 +1,31 @@
+post_install() {
+cat <<EOF
+---
+1. edit /usr/bin/ssh-faker (CHANGE THE DEFAULT PASSWORD!)
+2. echo sshd : 11.22.33.44 : ALLOW >> /etc/hosts.allow
+3. echo sshd : ALL : twist /usr/bin/ssh-faker %a >> /etc/hosts.deny
+4. test it:
+
+ # ssh localhost
+ Received disconnect from 127.0.0.1: Your ssh version is too
+ old and is no longer supported. Please install a newer version.
+
+ # telnet localhost 22
+ Trying 127.0.0.1...
+ Connected to localhost.
+ Escape character is '^]'.
+ SSH-1.99-OpenSSH_3.7.1p1
+ >> password
+ Success! You can now ssh to this computer.
+ Connection closed by foreign host.
+
+ # ssh localhost
+ Last login: Sat Jul 16 11:37:38 2005 from localhost.localdomain
+---
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
+