summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortarik022025-01-11 15:35:44 +0200
committertarik022025-01-11 15:47:24 +0200
commit3dd0b5ffa0f0a63112161b7e1525f5d81b0b82d6 (patch)
tree50dfde886870421890e90be77ed6ad4b33740fa6
downloadaur-ssh-ggh-bin.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD24
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8aa8981580f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ssh-ggh-bin
+ pkgdesc = Recall your SSH sessions (also search your SSH config file)
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/byawitz/ggh
+ arch = x86_64
+ arch = aarch64
+ license = Apache-2.0
+ depends = openssh
+ provides = ssh-ggh
+ conflicts = ssh-ggh
+ conflicts = ssh-ggh-git
+ source_x86_64 = ggh-x86_64::https://github.com/byawitz/ggh/releases/download/v0.1.4/ggh_linux_x86_64
+ sha256sums_x86_64 = ae5675d6833c4c6ff558413599f53a6e248935aa96725d18029ecf763ee01909
+ source_aarch64 = ggh-aarch64::https://github.com/byawitz/ggh/releases/download/v0.1.4/ggh_linux_arm64
+ sha256sums_aarch64 = ffba529da2bfe08f457f27feb12d5a720cb078de9b4badb55db74eaad866259a
+
+pkgname = ssh-ggh-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..76abce393e0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: tarik02 <taras[dot]fomin[at]gmail[dot]com>
+
+pkgname=ssh-ggh-bin
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Recall your SSH sessions (also search your SSH config file)"
+arch=('x86_64' 'aarch64')
+url="https://github.com/byawitz/ggh"
+license=('Apache-2.0')
+
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
+depends=(openssh)
+
+source_x86_64=("ggh-x86_64::https://github.com/byawitz/ggh/releases/download/v${pkgver}/ggh_linux_x86_64")
+source_aarch64=("ggh-aarch64::https://github.com/byawitz/ggh/releases/download/v${pkgver}/ggh_linux_arm64")
+
+sha256sums_x86_64=('ae5675d6833c4c6ff558413599f53a6e248935aa96725d18029ecf763ee01909')
+sha256sums_aarch64=('ffba529da2bfe08f457f27feb12d5a720cb078de9b4badb55db74eaad866259a')
+
+package() {
+ # bin
+ install -Dm755 "$srcdir/ggh-$CARCH" "${pkgdir}/usr/bin/ggh"
+}