summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFoppe Hemminga2015-07-07 13:40:13 +0200
committerFoppe Hemminga2015-07-07 13:40:13 +0200
commit65b703e1289a9fbc11b38d6b3bf1e4173a9859f6 (patch)
treed33be56133a81546f072824104aac920a76cdc60
downloadaur-ssh-restrict-git.tar.gz
Initial commit copy of AUR3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96934254fee3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ssh-restrict-git
+ pkgdesc = whitelist remote commands via ssh config
+ pkgver = 20150523
+ pkgrel = 1
+ url = https://github.com/mxey/ssh-restrict
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python2
+ depends = python2-configparser
+ source = ssh-restrict::git+https://github.com/mxey/ssh-restrict.git#branch=HEAD
+ md5sums = SKIP
+
+pkgname = ssh-restrict-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ad7891aba31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Foppe Hemminga "Afwas" <foppe@foppe.org>
+
+pkgname=ssh-restrict-git
+_pkgname=ssh-restrict
+pkgver=20150523
+pkgrel=1
+pkgdesc="whitelist remote commands via ssh config"
+arch=('any')
+url="https://github.com/mxey/ssh-restrict"
+license=('BSD')
+makedepends=('git')
+depends=('python2' 'python2-configparser')
+source=("${_pkgname}::git+https://github.com/mxey/${_pkgname}.git#branch=HEAD")
+md5sums=('SKIP')
+
+build() {
+ sed -i.bak 's/python/python2/' "${srcdir}/${_pkgname}/ssh-restrict"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/licences/${_pkgname}"
+ install -Dm644 "ssh-restrict" "${pkgdir}/usr/bin/ssh-restrict"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}"
+
+ chmod +x "${pkgdir}/usr/bin/${_pkgname}"
+}