summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenBrahe2018-11-20 13:55:36 +0100
committerDenBrahe2018-11-20 13:55:36 +0100
commitcc2344d0d9ae2e3fbd87816a419531bcfddca3eb (patch)
treec491673841741865e892683049ca30700e5a03c2
parentd8f42d1c712c9db9109606af74ae44516f4eeb0d (diff)
downloadaur-stack-cloud-client.tar.gz
rename patch
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
-rw-r--r--rename.patch13
3 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 202565afcf7a..62d83c67c85a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = stack-client
- pkgdesc = The STACK Client provides file sync to desktop clients.
+pkgbase = stack-cloud-client
+ pkgdesc = The STACK Client provides file sync to desktop clients. Renamed due to name clash with Haskell Tool Stack
pkgver = 2.4.1
- pkgrel = 3
+ pkgrel = 1
url = https://www.transip.nl/stack/
arch = x86_64
license = GPL2
@@ -14,12 +14,15 @@ pkgbase = stack-client
optdepends = python2-nautilus: integration with Nautilus
optdepends = nemo-python: integration with Nemo
conflicts = stack-client-bin
+ conflicts = stack-client
source = client-v2.4.1.tar.gz::https://github.com/owncloud/client/archive/v2.4.1.tar.gz
source = http://mirror.transip.net/stack/software/source/stack-client-source-2.4.1.tar.gz
source = cmake_qt5.patch
+ source = rename.patch
sha256sums = 89a29ce91f49160cae4f04129a9d1e0757b665300db68d4449849c847627d337
sha256sums = 802b9032408118cff2852965f8c0ae87733205db86a8d386c2a4fb3c43e9a4d8
sha256sums = 25ab3c8010f5b031bad4b671d80487889506b43e42b3f16f2329e58bfabe5fae
+ sha256sums = 30188b01acf74ca4c32540e6c31a10e380fad6a0e3aecfbbf07c21fcba5252a7
-pkgname = stack-client
+pkgname = stack-cloud-client
diff --git a/PKGBUILD b/PKGBUILD
index f6d08b410834..7c58b24ae730 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,12 @@
-pkgname=stack-client
+# Maintainer: DenBrahe <denbrahe at hotmail dot com>
+# Contributor: rubenvb <vanboxem dot ruben at gmail dot com>
+#
+# Based on stack-client package
+
+pkgname=stack-cloud-client
pkgver=2.4.1
-pkgrel=3
-pkgdesc="The STACK Client provides file sync to desktop clients."
+pkgrel=1
+pkgdesc="The STACK Client provides file sync to desktop clients. Renamed due to name clash with Haskell Tool Stack"
arch=('x86_64')
url='https://www.transip.nl/stack/'
license=(GPL2)
@@ -9,13 +14,15 @@ depends=('qtkeychain' 'qt5-webkit' 'hicolor-icon-theme' 'xdg-utils')
optdepends=('python2-nautilus: integration with Nautilus' 'nemo-python:
integration with Nemo')
makedepends=('cmake' 'qt5-tools')
-conflicts=('stack-client-bin')
+conflicts=('stack-client-bin' 'stack-client')
source=("client-v${pkgver}.tar.gz::https://github.com/owncloud/client/archive/v${pkgver}.tar.gz"
"http://mirror.transip.net/stack/software/source/stack-client-source-${pkgver}.tar.gz"
- "cmake_qt5.patch")
+ "cmake_qt5.patch"
+ "rename.patch")
sha256sums=('89a29ce91f49160cae4f04129a9d1e0757b665300db68d4449849c847627d337'
'802b9032408118cff2852965f8c0ae87733205db86a8d386c2a4fb3c43e9a4d8'
- '25ab3c8010f5b031bad4b671d80487889506b43e42b3f16f2329e58bfabe5fae')
+ '25ab3c8010f5b031bad4b671d80487889506b43e42b3f16f2329e58bfabe5fae'
+ '30188b01acf74ca4c32540e6c31a10e380fad6a0e3aecfbbf07c21fcba5252a7')
prepare() {
patch -p1 < ${srcdir}/cmake_qt5.patch
@@ -24,6 +31,8 @@ prepare() {
do
patch -p1 < ${file}
done
+ cd ${srcdir}/transiptheme
+ patch -Np1 -i ${srcdir}/rename.patch
}
build() {
@@ -33,7 +42,7 @@ build() {
cmake ../client-2.4.1 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DLINUX_PACKAGE_SHORTNAME=stack \
+ -DLINUX_PACKAGE_SHORTNAME=stack-cloud \
-DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname} \
-DWITH_DOC=FALSE \
diff --git a/rename.patch b/rename.patch
new file mode 100644
index 000000000000..aa8a60451bfd
--- /dev/null
+++ b/rename.patch
@@ -0,0 +1,13 @@
+diff -ura transiptheme/OEM.cmake transiptheme.new/OEM.cmake
+--- transiptheme/OEM.cmake 2018-03-09 11:10:44.000000000 +0100
++++ transiptheme.new/OEM.cmake 2018-11-20 12:39:41.227759663 +0100
+@@ -1,7 +1,7 @@
+ # Generated by OWNBRANDER on Mon, 25 Apr 2016 15:49:22 +0000
+-set( APPLICATION_SHORTNAME "stack" )
++set( APPLICATION_SHORTNAME "stack-cloud" )
+ set( APPLICATION_NAME "STACK" )
+-set( APPLICATION_EXECUTABLE "stack" )
++set( APPLICATION_EXECUTABLE "stack-cloud" )
+ set( APPLICATION_DOMAIN "transip.nl/stack" )
+ set( APPLICATION_VENDOR "TransIP" )
+ set( APPLICATION_REV_DOMAIN "nl.transip.stack" )