summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2012-02-12 14:10:25 +0000
committerThomas Weißschuh2012-02-12 14:10:25 +0000
commitf452fd26b22114dc56c1fee0a9f3afe2a312df1b (patch)
tree59265df84729160ca5b0a5f639f62bba12949f4e
downloadaur-stacktrace.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a6561e151c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = stacktrace
+ pkgdesc = Javalike stacktrace for ELF binaries
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://www.nopcode.org/wk.php/stacktrace
+ arch = any
+ license = GPL
+ source = http://kung-foo.net/killabyte/code/stacktrace/stacktrace-1.2.1.tar.gz
+ sha1sums = 9e6e632dfe72baa95d95e2aa9c32054b673cec2a
+
+pkgname = stacktrace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e20dde828bd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Thomas Weißschuh <thomas_weissschuh || lavabit || com>
+
+pkgname=stacktrace
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Javalike stacktrace for ELF binaries"
+arch=(any)
+url="http://www.nopcode.org/wk.php/stacktrace"
+license=("GPL")
+source=("http://kung-foo.net/killabyte/code/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('9e6e632dfe72baa95d95e2aa9c32054b673cec2a')
+
+build(){
+ cd ${srcdir}/${pkgname}-${pkgver}/
+ make
+}
+
+
+package(){
+ cd ${srcdir}/${pkgname}-${pkgver}/
+ make \
+ DOCDIR=${pkgdir}/usr/share/doc/${pkgname} \
+ BINDIR=${pkgdir}/usr/bin \
+ INCDIR=${pkgdir}/usr/include \
+ LIBDIR=${pkgdir}/usr/lib \
+ install
+}
+# vim: sw=2:ts=2 et: