summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaffaele Mancuso2023-10-29 12:04:01 +0100
committerRaffaele Mancuso2023-10-29 12:04:01 +0100
commitf4bf5d190708e70d5597d3f06adad8f36c56caf3 (patch)
tree880bb6636426db101e1d3d280580bc27901e1bb7
downloadaur-stardict-bobotig-es.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05aaf4d32f40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = stardict-bobotig-es
+ pkgdesc = Spanish monolingual dictionary, based on Wiktionary, StarDict file format, BoboTiG's daily dumps
+ pkgver = 2023_10_20
+ pkgrel = 1
+ url = https://github.com/BoboTiG/ebook-reader-dict
+ arch = any
+ license = cc-by-sa-3.0
+ source = https://github.com/BoboTiG/ebook-reader-dict/releases/download/es/dict-es-es.zip
+ source = https://github.com/BoboTiG/ebook-reader-dict/releases/download/es/dict-es-es.zip.sha256
+ b2sums = SKIP
+ b2sums = SKIP
+
+pkgname = stardict-bobotig-es
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3bfd6a0bb1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Raffaele Mancuso <raffaelemancuso532@gmail.com>
+_lang=es
+_langfull=Spanish
+pkgname="stardict-bobotig-${_lang}"
+pkgver=2023_10_20
+pkgrel=1
+pkgdesc="${_langfull} monolingual dictionary, based on Wiktionary, StarDict file format, BoboTiG's daily dumps"
+arch=("any")
+url="https://github.com/BoboTiG/ebook-reader-dict"
+license=('cc-by-sa-3.0')
+source=("https://github.com/BoboTiG/ebook-reader-dict/releases/download/${_lang}/dict-${_lang}-${_lang}.zip"{,.sha256})
+b2sums=("SKIP"
+ "SKIP")
+
+pkgver() {
+ sed -n 's/^date=//p' dict-data.ifo | sed 's/-/_/g'
+}
+
+package() {
+ sha256sum --strict --check "dict-${_lang}-${_lang}.zip.sha256"
+ if [ "$?" -ne 0 ]; then
+ echo "Checksum is wrong. Aborting"
+ exit
+ else
+ echo "Checksum OK"
+ fi
+ install -Dm644 dict-data.dict.dz dict-data.idx dict-data.ifo -t "${pkgdir}/usr/share/stardict/dic/bobotig-${_lang}"
+ if [ -f dict-data.syn ]; then
+ install -Dm644 dict-data.syn -t "${pkgdir}/usr/share/stardict/dic/bobotig-${_lang}"
+ fi
+ if [ -d ./res ]; then
+ install -Dm644 ./res/* -t "${pkgdir}/usr/share/stardict/dic/bobotig-${_lang}/res"
+ fi
+}