summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Velichko2015-07-12 01:41:46 +0300
committerIgor Velichko2015-07-12 01:41:46 +0300
commit7c0a1308472f7f493391a0d90cbd4e2cb5009680 (patch)
tree0943d42667a528745756b1ec1c2ded63cc75b029
downloadaur-stardict-reduced.tar.gz
Reduced Stardict 3.0.6
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD68
-rw-r--r--gcc46.patch11
-rw-r--r--glib2.patch36
4 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a81bdba9a81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = stardict-reduced
+ pkgdesc = International dictionary software - very reduced version with offline dictionaries support only
+ pkgver = 3.0.6
+ pkgrel = 1
+ url = http://www.stardict.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = popt
+ makedepends = gnome-doc-utils
+ makedepends = gnome-common
+ depends = gtk2
+ depends = libsigc++
+ depends = libsm
+ provides = stardict=3.0.6
+ conflicts = stardict
+ conflicts = stardict-lite
+ options = !libtool
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/project/stardict-4/3.0.6/stardict-3.0.6.tar.bz2
+ source = gcc46.patch
+ source = glib2.patch
+ md5sums = 93371b35482e6380e8bd4ba5d256b864
+ md5sums = 52ff47441c503de07add4b7688510bc5
+ md5sums = b2f216897c9053c7e4666c3d78705cf1
+
+pkgname = stardict-reduced
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c75b5a9590df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Contributor: Felix Yan <felixonmars@gmail.com>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Neil Lin <neil@vip.url.com.tw>
+# Contributor: OramahMaalhur <oramahmaalhur@gmail.com>
+
+pkgname=stardict-reduced
+pkgver=3.0.6
+pkgrel=1
+pkgdesc='International dictionary software - very reduced version with offline dictionaries support only'
+arch=('i686' 'x86_64')
+url='http://www.stardict.org/'
+license=('GPL')
+depends=('gtk2' 'libsigc++' 'libsm')
+makedepends=('intltool' 'popt' 'gnome-doc-utils' 'gnome-common')
+#makedepends=('intltool' 'popt' 'gnome-doc-utils' 'gnome-common' 'libmariadbclient' 'enchant' 'gtk2' 'libsigc++' 'libsm' 'espeak' 'libgnome')
+options=('!libtool' '!emptydirs')
+conflicts=('stardict' 'stardict-lite')
+provides=("stardict=$pkgver")
+source=("http://downloads.sourceforge.net/project/stardict-4/$pkgver/stardict-$pkgver.tar.bz2"
+ 'gcc46.patch'
+ 'glib2.patch')
+md5sums=('93371b35482e6380e8bd4ba5d256b864'
+ '52ff47441c503de07add4b7688510bc5'
+ 'b2f216897c9053c7e4666c3d78705cf1')
+
+build() {
+ cd "${srcdir}/stardict-${pkgver}"
+
+ patch -p1 -i ../gcc46.patch
+ patch -p1 -i ../glib2.patch
+ ./autogen.sh
+ ./configure \
+ PKG_CONFIG=/usr/bin/pkg-config \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --disable-schemas-install \
+ --disable-qqwry \
+ --disable-espeak \
+ --disable-gucharmap \
+ --disable-festival \
+ --disable-updateinfo \
+ --disable-dictdotcn \
+ --disable-qqwry \
+ --disable-advertisement \
+ --disable-spell \
+ --disable-wordnet \
+ --disable-man \
+ --disable-tools \
+ --disable-htmlparse \
+ --disable-xfdfparse \
+ --disable-powerwordparse \
+ --disable-wikiparse \
+ --disable-gtk-doc \
+ --disable-scrollkeeper \
+ --disable-deprecations
+ #--disable-gnome-support
+ #--disable-darwin-support \
+ #--disable-maemo-support \
+ #--disable-gpe-support
+
+ make
+}
+
+package() {
+ cd "${srcdir}/stardict-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/gcc46.patch b/gcc46.patch
new file mode 100644
index 000000000000..944b9635c7cb
--- /dev/null
+++ b/gcc46.patch
@@ -0,0 +1,11 @@
+diff -aur old/dict/stardict-plugins/stardict-wordnet-plugin/utils.h new/dict/stardict-plugins/stardict-wordnet-plugin/utils.h
+--- old/dict/stardict-plugins/stardict-wordnet-plugin/utils.h 2011-07-18 06:58:58.519404744 -0700
++++ new/dict/stardict-plugins/stardict-wordnet-plugin/utils.h 2011-07-18 07:01:10.739734313 -0700
+@@ -26,6 +26,7 @@
+ #ifndef __TYPES_H__
+ #define __TYPES_H__
+
++#include <cstddef>
+ #include <math.h>
+
+ typedef float single;
diff --git a/glib2.patch b/glib2.patch
new file mode 100644
index 000000000000..bd0f6bac80e5
--- /dev/null
+++ b/glib2.patch
@@ -0,0 +1,36 @@
+diff -Naur old/dict/configure.ac new/dict/configure.ac
+--- old/dict/configure.ac 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/configure.ac 2012-07-12 22:31:52.875176842 +1000
+@@ -266,6 +266,9 @@
+ fi
+ AC_SUBST(WIKI_PARSEDATA_PLUGIN_DIR)
+
++GMODULE2_LIBS=`pkg-config --libs gmodule-2.0`
++AC_SUBST([GMODULE2_LIBS])
++
+ dnl ================================================================
+ dnl main program checks.
+ dnl ================================================================
+diff -Naur old/dict/src/Makefile.am new/dict/src/Makefile.am
+--- old/dict/src/Makefile.am 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/src/Makefile.am 2012-07-12 22:29:53.714870692 +1000
+@@ -33,7 +33,7 @@
+ stardict_DEPENDENCIES = lib/libstardict.la $(LOCAL_SIGCPP_LIBFILE)
+ stardict_LDFLAGS =
+ ## place libstardict.la before any system library, otherwise build with --as-needed linker option may fail
+-stardict_LDADD = lib/libstardict.la $(STARDICT_LIBS) $(LOCAL_SIGCPP_LIBFILE)
++stardict_LDADD = lib/libstardict.la $(STARDICT_LIBS) $(LOCAL_SIGCPP_LIBFILE) $(GMODULE2_LIBS)
+
+ if !GNOME_SUPPORT
+ if MAEMO_SUPPORT
+diff -Naur old/dict/src/tomboykeybinder.h new/dict/src/tomboykeybinder.h
+--- old/dict/src/tomboykeybinder.h 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/src/tomboykeybinder.h 2012-07-12 22:28:04.337920391 +1000
+@@ -21,7 +21,6 @@
+ #ifndef __TOMBOY_KEY_BINDER_H__
+ #define __TOMBOY_KEY_BINDER_H__
+
+-#include <glib.h>
+
+ G_BEGIN_DECLS
+