summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDhananjay Tanpure2021-12-15 11:41:33 +0530
committerDhananjay Tanpure2021-12-15 11:41:33 +0530
commite93a0452cbb278d62de56d63f25c030f5245d9ca (patch)
tree4d4d04ee402fdebd10f59816d87a092ba3454de9
parent24394d3cf32e26a5a6e4d53e9d9146cf7c014869 (diff)
downloadaur-station.tar.gz
Version 2.0.9 Released
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56b2d61d771a..318aaebd1bc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = station
pkgdesc = The one app to rule them all
- pkgver = 1.65.0
+ pkgver = 2.0.9
pkgrel = 1
url = https://getstation.com/
arch = x86_64
license = MIT
- source = https://github.com/getstation/desktop-app-releases/releases/download/1.65.0/Station-1.65.0-x86_64.AppImage
- sha256sums = 41655ce242f1d15962e4232f0611d707602a4a4f4cd1539a6303b50cf99af3d7
+ source = https://github.com/getstation/desktop-app/releases/download/v2.0.9/Station-x86_64.AppImage
+ sha256sums = b0e63ac044ebee0b917f0537d0300a4ffc55f657c62618709e4ff6e91f59b327
pkgname = station
-
diff --git a/PKGBUILD b/PKGBUILD
index 9e6d66728c87..5a75f47e5719 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Naoki Kanazawa <nk dot naoki912 at gmail dot com>
+# Maintainer: Dhananjay Tanpure <dtan13@pm.me>
+# Contributor: Naoki Kanazawa <nk dot naoki912 at gmail dot com>
# Contributor: Yegorius <yegorius at domic dot us>
pkgname=station
-pkgver=1.65.0
+pkgver=2.0.9
pkgrel=1
pkgdesc='The one app to rule them all'
arch=('x86_64')
@@ -9,13 +10,13 @@ url='https://getstation.com/'
license=('MIT')
#depends=('gtk2' 'gconf' 'xdg-utils' 'libxtst' 'libxss' 'nss' 'alsa-lib' 'xdg-utils')
source=(
- "https://github.com/getstation/desktop-app-releases/releases/download/${pkgver}/Station-${pkgver}-x86_64.AppImage"
+ "https://github.com/getstation/desktop-app/releases/download/v${pkgver}/Station-x86_64.AppImage"
)
-sha256sums=('41655ce242f1d15962e4232f0611d707602a4a4f4cd1539a6303b50cf99af3d7')
+sha256sums=('b0e63ac044ebee0b917f0537d0300a4ffc55f657c62618709e4ff6e91f59b327')
prepare() {
- chmod u+x ./Station-${pkgver}-x86_64.AppImage
- ./Station-${pkgver}-x86_64.AppImage --appimage-extract
+ chmod u+x ./Station-x86_64.AppImage
+ ./Station-x86_64.AppImage --appimage-extract
}
package() {
@@ -30,7 +31,7 @@ package() {
cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share"
chmod -R 755 "${pkgdir}/usr/share/icons"
- sed -i -e 's/AppRun/station/' "${pkgdir}/usr/lib/${pkgname}/browserx.desktop"
- ln -s "/usr/lib/${pkgname}/browserx.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- ln -s "/usr/lib/${pkgname}/browserx" "${pkgdir}/usr/bin/${pkgname}"
+ sed -i -e 's/AppRun/station/' "${pkgdir}/usr/lib/${pkgname}/station-desktop-app.desktop"
+ ln -s "/usr/lib/${pkgname}/station-desktop-app.desktop" "${pkgdir}/usr/share/applications/station-desktop-app.desktop"
+ ln -s "/usr/lib/${pkgname}/station-desktop-app" "${pkgdir}/usr/bin/${pkgname}"
}