summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2022-04-27 22:04:03 +0200
committerKr1ss2022-04-27 22:04:03 +0200
commit0e059604985e22f3fd30eb855c7d55b5b7e1773a (patch)
tree5666d9d28563f9538b7aded5a55c860f6102cebe
downloadaur-stegsnow-git.tar.gz
initial upload: stegsnow-git 2020.04.07.g69c5029-1
-rw-r--r--.SRCINFO16
-rw-r--r--ChangeLog3
-rw-r--r--PKGBUILD42
-rw-r--r--stegsnow.patch120
4 files changed, 181 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54aee8e21d5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stegsnow-git
+ pkgdesc = Conceal messages in ASCII text by appending whitespace to the end of lines
+ pkgver = 2020.04.07.g69c5029
+ pkgrel = 1
+ url = http://www.darkside.com.au/snow
+ changelog = ChangeLog
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = glibc
+ source = git+https://salsa.debian.org/pkg-security-team/stegsnow.git
+ source = stegsnow.patch
+ sha256sums = SKIP
+ sha256sums = d27d97a950a99f649b705d03ef334fa33bfb76280cb6fcf21a73ad4c0fdcaafc
+
+pkgname = stegsnow-git
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..ee0beeee814e
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,3 @@
+2013-06-16 Matthew Kwan <mkwan@darkside.com.au>
+ - compress.c: Fixed some fprintf format warnings.
+ - Makefile: Added new compile flags.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96a4082e7311
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer : Kr1ss $(tr +- .@ <<<'<kr1ss+x-yandex+com>')
+# Contributor : ans <oscarlatorre(at)pm(dot)me>
+
+
+pkgname=stegsnow-git
+_name="${pkgname%-git}"
+
+pkgver() { git -C "$_name" log -n1 --format=%cs.g%h | tr - .; }
+pkgver=2020.04.07.g69c5029
+pkgrel=1
+
+pkgdesc='Conceal messages in ASCII text by appending whitespace to the end of lines'
+url="http://www.darkside.com.au/${_name#steg}"
+arch=('x86_64')
+license=('Apache')
+
+makedepends=('git')
+depends=('glibc')
+
+changelog=ChangeLog
+source=("git+https://salsa.debian.org/pkg-security-team/$_name.git" "$_name.patch")
+sha256sums=('SKIP' 'd27d97a950a99f649b705d03ef334fa33bfb76280cb6fcf21a73ad4c0fdcaafc')
+
+
+prepare() {
+ cd "$_name"
+ patch -Np1 -i "../$_name.patch"
+}
+
+build() {
+ cd "$_name"
+ make
+}
+
+package() {
+ cd "$_name"
+ install -Dm755 "$_name" -t"$pkgdir/usr/bin/"
+ install -Dm644 "$_name.1" -t"$pkgdir/usr/share/man/man1/"
+}
+
+
+# vim: ts=2 sw=2 et ft=PKGBUILD:
diff --git a/stegsnow.patch b/stegsnow.patch
new file mode 100644
index 000000000000..327781f07aad
--- /dev/null
+++ b/stegsnow.patch
@@ -0,0 +1,120 @@
+From 7da9659c131ab2d8b95d7a0dace8f5da41f371f8 Mon Sep 17 00:00:00 2001
+From: Oscar Latorre <oscarlatorre7896@gmail.com>
+Date: Fri, 19 Jan 2018 02:42:45 +0100
+Subject: [PATCH] Renamed to stegsnow
+
+---
+ Makefile | 2 +-
+ snow.1 => stegsnow.1 | 24 ++++++++++++------------
+ 2 files changed, 13 insertions(+), 13 deletions(-)
+ rename snow.1 => stegsnow.1 (84%)
+
+diff --git a/Makefile b/Makefile
+index 1fcc80d..90c17e8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ CFLAGS ?= -O
+
+ OBJ = main.o encrypt.o ice.o compress.o encode.o
+
+-snow: $(OBJ)
++stegsnow: $(OBJ)
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJ)
+
+ clean:
+diff --git a/snow.1 b/stegsnow.1
+similarity index 84%
+rename from snow.1
+rename to stegsnow.1
+index c754bdd..f35f808 100644
+--- a/snow.1
++++ b/stegsnow.1
+@@ -1,8 +1,8 @@
+-.TH SNOW 1 "28 Dec 1996" "Version 1.1"
++.TH STEGSNOW 1 "28 Dec 1996" "Version 1.1"
+ .SH NAME
+-snow \- whitespace steganography program
++stegsnow \- whitespace steganography program
+ .SH SYNOPSIS
+-.B snow
++.B stegsnow
+ [
+ .B -CQS
+ ] [
+@@ -31,7 +31,7 @@ snow \- whitespace steganography program
+ .I outfile
+ ]]
+ .SH DESCRIPTION
+-\fBsnow\fP is a program for concealing messages in text files
++\fBstegsnow\fP is a program for concealing messages in text files
+ by appending tabs and spaces on the end of lines, and for
+ extracting messages from files containing hidden messages.
+ Tabs and spaces are invisible to most text viewers, hence the
+@@ -48,7 +48,7 @@ The start of the data is indicated by an appended tab character, which
+ allows the insertion of mail and news headers without corrupting
+ the data.
+ .PP
+-\fBsnow\fP provides rudimentary compression, using Huffman tables
++\fBstegsnow\fP provides rudimentary compression, using Huffman tables
+ optimised for English text. However, if the data is not text, or if
+ there is a lot of data, the use of the built-in compression is not
+ recommended, since an external compression program such as
+@@ -61,11 +61,11 @@ key size, passwords of any length up to 1170 characters are supported
+ are supported).
+ .PP
+ If a message string or message file are specified on the command-line,
+-\fBsnow\fP will attempt to conceal the message in the file \fIinfile\fP
++\fBstegsnow\fP will attempt to conceal the message in the file \fIinfile\fP
+ if specified, or standard input otherwise. The resulting file will be
+ written to \fIoutfile\fP if specified, or standard output if not.
+ .PP
+-If no message string is provided, \fBsnow\fP attempts to extract a
++If no message string is provided, \fBstegsnow\fP attempts to extract a
+ message from the input file. The result is written to the output file
+ or standard output.
+ .SH OPTIONS
+@@ -77,7 +77,7 @@ Compress the data if concealing, or uncompress it if extracting.
+ The contents of this file will be concealed in the input text file.
+ .TP
+ \fB-l\fP \fIline-len\fP
+-When appending whitespace, \fBsnow\fP will always produce lines shorter
++When appending whitespace, \fBstegsnow\fP will always produce lines shorter
+ than this value. By default it is set to 80.
+ .TP
+ \fB-m\fP \fImessage-string\fP
+@@ -109,13 +109,13 @@ file \fIinfile\fP, with compression, and encrypted with the password
+ "hello world". The resulting text will be stored in \fIoutfile\fP.
+ .PP
+ .RS
+-\fBsnow \-C \-m "I am lying" \-p "hello world" infile outfile\fP
++\fBstegsnow \-C \-m "I am lying" \-p "hello world" infile outfile\fP
+ .RE
+ .PP
+ To extract the message, the command would be
+ .PP
+ .RS
+-\fBsnow \-C \-p "hello world" outfile\fP
++\fBstegsnow \-C \-p "hello world" outfile\fP
+ .RE
+ .PP
+ Note that the resulting message will not be terminated by a newline.
+@@ -125,14 +125,14 @@ be indented by mail or news readers, a line length of 72 or less can
+ be used.
+ .PP
+ .RS
+-\fBsnow \-C \-l 72 \-m "I am lying" infile outfile\fP
++\fBstegsnow \-C \-l 72 \-m "I am lying" infile outfile\fP
+ .RE
+ .PP
+ The approximate storage capacity of a file can be determined with
+ the \fB-S\fP option.
+ .PP
+ .RS
+-\fBsnow \-S \-l 72 infile\fP
++\fBstegsnow \-S \-l 72 infile\fP
+ .RE
+ .SH AUTHOR
+ This application was written by Matthew Kwan, who can be reached at
+--
+2.15.1
+