summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-06-10 19:05:15 +0300
committerMr.Smith19742023-06-10 19:05:15 +0300
commit456c743c5e3a07cbb1d8133eab0ce572817c8537 (patch)
tree5ff676e5126cd6d94b7853a6a8ed62311cd0cff7
downloadaur-stendhal-bin.tar.gz
Initial build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--stendhal4
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ce06cd85948
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = stendhal-bin
+ pkgdesc = Stendhal is a fun friendly and free multiplayer online adventure game with an old school feel.
+ pkgver = 1.4.3
+ pkgrel = 1
+ url = https://stendhalgame.org/
+ arch = any
+ license = GPL2
+ depends = java-environment-common
+ source = https://arianne-project.org/download/stendhal.zip
+ source = stendhal
+ sha256sums = dffeb98c9e8e28265f873f087e2abee74fcb5b0b3874884efc8c044470645d7c
+ sha256sums = 5d29bc01ccc575e62d145d4826d962bc0ade872538c8e5888415b0f98e942aaf
+
+pkgname = stendhal-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec720fb82cee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=stendhal-bin
+_pkgname=stendhal
+pkgver=1.4.3
+pkgrel=1
+pkgdesc="Stendhal is a fun friendly and free multiplayer online adventure game with an old school feel."
+arch=('any')
+url="https://stendhalgame.org/"
+depends=('java-environment-common')
+license=('GPL2')
+source=("https://arianne-project.org/download/stendhal.zip"
+ "stendhal")
+sha256sums=('dffeb98c9e8e28265f873f087e2abee74fcb5b0b3874884efc8c044470645d7c'
+ '5d29bc01ccc575e62d145d4826d962bc0ade872538c8e5888415b0f98e942aaf')
+
+
+package() {
+ cd ${srcdir}
+
+ mkdir -p ${pkgdir}/opt/${_pkgname}
+ cp stendhal-starter.jar ${pkgdir}/opt/${_pkgname}
+ cp -r {doc,lib,log} ${pkgdir}/opt/${_pkgname}
+
+ cd ${srcdir}
+ install -D -m755 stendhal ${pkgdir}/usr/bin/stendhal
+}
+
diff --git a/stendhal b/stendhal
new file mode 100644
index 000000000000..a947f2f82b62
--- /dev/null
+++ b/stendhal
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd /opt/stendhal/
+java -Xmx8192m -jar stendhal-starter.jar
+exit