summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJni2016-06-03 22:12:46 -0400
committerJni2016-06-03 22:12:46 -0400
commit16d55c839c3cd320730bed4196ff941b8b7749ff (patch)
tree1d1f4de3f5ce658ae01dd5d478d0567f924b7cd1
downloadaur-stepman.tar.gz
Initial package creation, stepman version 0.9.19
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5305fd837252
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = stepman
+ pkgdesc = Manage decentralized StepLib Step (script) Collections.
+ pkgver = 0.9.19
+ pkgrel = 1
+ url = https://github.com/bitrise-io/stepman
+ arch = x86_64
+ license = MIT
+ provides = stepman
+ source = https://github.com/bitrise-io/stepman/releases/download/0.9.19/stepman-Linux-x86_64
+ source = https://raw.githubusercontent.com/bitrise-io/stepman/master/LICENSE
+ md5sums = 97482b1f85b0c7216dd6c0486d8d045d
+ md5sums = 10c39cc7466456c17298b32d04bfa8d9
+
+pkgname = stepman
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72b5254dc9f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Jni <jni.viens at protonmail dot com>
+pkgname=stepman
+pkgver=0.9.19
+pkgrel=1
+pkgdesc="Manage decentralized StepLib Step (script) Collections."
+arch=(x86_64)
+url="https://github.com/bitrise-io/stepman"
+license=('MIT')
+provides=(stepman)
+source=(https://github.com/bitrise-io/stepman/releases/download/$pkgver/$pkgname-Linux-$CARCH
+ https://raw.githubusercontent.com/bitrise-io/stepman/master/LICENSE)
+md5sums=('97482b1f85b0c7216dd6c0486d8d045d'
+ '10c39cc7466456c17298b32d04bfa8d9')
+
+package() {
+ install -Dm644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "$srcdir/$pkgname-Linux-$CARCH" "$pkgdir/usr/bin/stepman"
+}