summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTerin Stock2018-01-10 15:52:23 -0800
committerTerin Stock2018-01-10 15:55:34 -0800
commitcdaa38b53bbc18ffeefef73d34cea2d19d3ba13f (patch)
tree8f58f4cd4afad433bbf1a0720c033088cc85f488
parent720dfc3eeb5c902dbe48df85456af6b1298fad6c (diff)
downloadaur-cdaa38b53bbc18ffeefef73d34cea2d19d3ba13f.tar.gz
0.18-2: add Fedora patchdescr.tmpl patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
-rw-r--r--stgit-0.16-tmpl.patch22
3 files changed, 36 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b87d2411301..5aaa0bc4dd23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,9 @@ pkgbase = stgit
depends = python2
depends = git
source = https://github.com/ctmarinas/stgit/archive/v0.18.tar.gz
+ source = stgit-0.16-tmpl.patch
sha256sums = 00c83a0a057ee61a300f2291b8926f85521ffd1c92b4cb5152e2be3bf836d3a5
+ sha256sums = 98b8347845ee3d1dd15243608cab3c5d9e76caf0da0a5fa59020854450cd340c
pkgname = stgit
diff --git a/PKGBUILD b/PKGBUILD
index 42216ecd694d..a667c92ee5e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,24 @@
pkgname=stgit
pkgver=0.18
-pkgrel=1
+pkgrel=2
pkgdesc="Pushing/popping patches to/from a stack on top of Git, similar to Quilt"
url="http://www.procode.org/stgit/"
arch=('any')
license=('GPL')
depends=('python2' 'git')
makedepends=('xmlto' 'asciidoc')
-source=("https://github.com/ctmarinas/stgit/archive/v${pkgver}.tar.gz")
-sha256sums=('00c83a0a057ee61a300f2291b8926f85521ffd1c92b4cb5152e2be3bf836d3a5')
+source=(
+ "https://github.com/ctmarinas/stgit/archive/v${pkgver}.tar.gz"
+ "stgit-0.16-tmpl.patch"
+)
+sha256sums=('00c83a0a057ee61a300f2291b8926f85521ffd1c92b4cb5152e2be3bf836d3a5'
+ '98b8347845ee3d1dd15243608cab3c5d9e76caf0da0a5fa59020854450cd340c')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 -i "$srcdir"/stgit-0.16-tmpl.patch
+}
build() {
cd "$srcdir"/$pkgname-$pkgver
diff --git a/stgit-0.16-tmpl.patch b/stgit-0.16-tmpl.patch
new file mode 100644
index 000000000000..fee55b93fb01
--- /dev/null
+++ b/stgit-0.16-tmpl.patch
@@ -0,0 +1,22 @@
+diff -ur stgit-0.16.orig/stgit/commands/common.py stgit-0.16/stgit/commands/common.py
+--- stgit-0.16.orig/stgit/commands/common.py 2012-01-09 22:12:42.000000000 +0100
++++ stgit-0.16/stgit/commands/common.py 2012-12-04 19:04:52.193722114 +0100
+@@ -23,7 +23,7 @@
+ from stgit.utils import *
+ from stgit.out import *
+ from stgit.run import *
+-from stgit import stack, git, basedir
++from stgit import stack, git, basedir, templates
+ from stgit.config import config, file_extensions
+ from stgit.lib import stack as libstack
+ from stgit.lib import git as libgit
+@@ -499,6 +499,9 @@
+ # Let user edit the commit message manually, unless
+ # --save-template or --message was specified.
+ if not getattr(options, 'save_template', None) and options.message is None:
++ tmpl = templates.get_template('patchdescr.tmpl')
++ if tmpl:
++ cd = cd.set_message(cd.message + tmpl)
+ cd = cd.set_message(edit_string(cd.message, '.stgit-new.txt'))
+
+ return cd