summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkumencz2023-07-10 19:01:56 +0200
committerkumencz2023-07-10 19:01:56 +0200
commit7fd0ce92964fd260069cd1a9014cce41922b94c0 (patch)
tree0a86b977bc56768fc98454686c420051d74ea48d
parent2f3354fa1cb539317abe5fd173c8ac4ea146c272 (diff)
downloadaur-7fd0ce92964fd260069cd1a9014cce41922b94c0.tar.gz
Fixed "webkit2gtk" related issue.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 422b4c901f23..ac0b98bbff2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stm32cubeide
pkgdesc = Integrated Development Environment for STM32
pkgver = 1.12.1
- pkgrel = 4
+ pkgrel = 5
url = https://www.st.com/en/development-tools/stm32cubeide.html
arch = x86_64
license = custom:SLA0048
@@ -9,10 +9,10 @@ pkgbase = stm32cubeide
depends = glibc
depends = libusb
depends = ncurses5-compat-libs
+ depends = webkit2gtk
optdepends = jlink-software-and-documentation
optdepends = stlink
optdepends = arm-none-eabi-gdb
- optdepends = webkit2gtk
options = !strip
source = en.st-stm32cubeide_1.12.1_16088_20230420_1057_amd64.sh.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/30/a8/7a/1c/24/19/42/c0/stm32cubeide-lnx/files/st-stm32cubeide_1.12.1_16088_20230420_1057_amd64.sh.zip/jcr:content/translations/en.st-stm32cubeide_1.12.1_16088_20230420_1057_amd64.sh.zip
source = https://www.st.com/resource/en/license/SLA0048_STM32CubeIDE.pdf
diff --git a/PKGBUILD b/PKGBUILD
index 16927dd951f3..cc132dd833b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@ pkgname="stm32cubeide"
pkgver=1.12.1
_pkgver_ext=1.12.1_16088_20230420_1057
_pkg_file_name=en.st-stm32cubeide_1.12.1_16088_20230420_1057_amd64.sh.zip
-pkgrel=4
+pkgrel=5
pkgdesc="Integrated Development Environment for STM32"
arch=("x86_64")
makedepends=('imagemagick')
-depends=('glibc' 'libusb' 'ncurses5-compat-libs')
-optdepends=('jlink-software-and-documentation' 'stlink' 'arm-none-eabi-gdb' 'webkit2gtk')
+depends=('glibc' 'libusb' 'ncurses5-compat-libs' 'webkit2gtk')
+optdepends=('jlink-software-and-documentation' 'stlink' 'arm-none-eabi-gdb')
conflicts=()
url="https://www.st.com/en/development-tools/stm32cubeide.html"
license=('custom:SLA0048')
@@ -84,10 +84,12 @@ package() {
msg2 'Installation of binary files'
install -Dm755 /dev/stdin "${pkgdir}/usr/bin/${pkgname}" <<END
#!/bin/sh
+mkdir -p /tmp/SWT-GDBusServer
/opt/stm32cubeide/stm32cubeide "\$@"
END
install -Dm755 /dev/stdin "${pkgdir}/usr/bin/${pkgname}_wayland" <<END
#!/bin/sh
+mkdir -p /tmp/SWT-GDBusServer
/opt/stm32cubeide/stm32cubeide_wayland "\$@"
END