summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkumencz2023-06-13 20:21:40 +0200
committerkumencz2023-06-13 20:21:40 +0200
commitb01884053350ee97c80ac03dadad21f3024c32b4 (patch)
tree9f3e4efde773889cdb3fa11c0ab79ca6a88db93d
parentf5ec3bc0b135c63389095b5241ef460720a97132 (diff)
downloadaur-b01884053350ee97c80ac03dadad21f3024c32b4.tar.gz
Create symlink with original directory name, do not use system gdb by default
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf398cf89cd3..88c2ba9eb8e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = stm32cubeide
pkgdesc = Integrated Development Environment for STM32
pkgver = 1.12.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.st.com/en/development-tools/stm32cubeide.html
arch = x86_64
license = Commercial
makedepends = imagemagick
depends = glibc
depends = libusb
- depends = arm-none-eabi-gdb
optdepends = jlink-software-and-documentation
optdepends = stlink
+ optdepends = arm-none-eabi-gdb
optdepends = webkit2gtk
options = !strip
source = en.st-stm32cubeide_1.12.1_16088_20230420_1057_amd64.sh.zip::https://www.st.com/content/ccc/resource/technical/software/sw_development_suite/group0/30/a8/7a/1c/24/19/42/c0/stm32cubeide-lnx/files/st-stm32cubeide_1.12.1_16088_20230420_1057_amd64.sh.zip/jcr:content/translations/en.st-stm32cubeide_1.12.1_16088_20230420_1057_amd64.sh.zip
diff --git a/PKGBUILD b/PKGBUILD
index 504f96faeed8..f44f197688fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@ pkgname="stm32cubeide"
pkgver=1.12.1
_pkgver_ext=1.12.1_16088_20230420_1057
_pkg_file_name=en.st-stm32cubeide_1.12.1_16088_20230420_1057_amd64.sh.zip
-pkgrel=1
+pkgrel=2
pkgdesc="Integrated Development Environment for STM32"
arch=("x86_64")
makedepends=('imagemagick')
-depends=('glibc' 'libusb' 'arm-none-eabi-gdb')
-optdepends=('jlink-software-and-documentation' 'stlink' 'webkit2gtk')
+depends=('glibc' 'libusb')
+optdepends=('jlink-software-and-documentation' 'stlink' 'arm-none-eabi-gdb' 'webkit2gtk')
conflicts=()
url="https://www.st.com/en/development-tools/stm32cubeide.html"
license=('Commercial')
@@ -111,11 +111,14 @@ Type=Application
Categories=Development;IDE;Java;
END
- msg2 'Replace GDB by system'
- rm "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin/arm-none-eabi-gdb
- rm "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin/arm-none-eabi-gdb-add-index
- ln -s /usr/bin/arm-none-eabi-gdb "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin
- ln -s /usr/bin/arm-none-eabi-gdb-add-index "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin
+ #msg2 'Replace GDB by system'
+ #rm "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin/arm-none-eabi-gdb
+ #rm "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin/arm-none-eabi-gdb-add-index
+ #ln -s /usr/bin/arm-none-eabi-gdb "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin
+ #ln -s /usr/bin/arm-none-eabi-gdb-add-index "${pkgdir}/opt/stm32cubeide/plugins/"com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32*/tools/bin
+
+ msg2 'Create symlink from original directory name'
+ ln -s "${pkgdir}/opt/stm32cubeide" "${pkgdir}/opt/stm32cubeide_${pkgver}"
msg2 'Installation of license file'
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"