summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKivApple2015-06-11 01:21:28 +0300
committerKivApple2015-06-11 01:21:28 +0300
commit3962d30b8f90169711d2bb050405474b27cf8a7b (patch)
tree561231d8fd04f4519ba1638c4aa176d6e9a60032
downloadaur-stm8-spl-sdcc.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be0d235e0b64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.1
+# Sun May 17 06:21:10 UTC 2015
+pkgbase = stm8-spl-sdcc
+ pkgdesc = Port of STM8 SPL for SDCC
+ pkgver = 20150517
+ pkgrel = 3
+ url = https://github.com/gicking/SPL_2.2.0_SDCC_patch
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = wget
+ makedepends = patch
+ makedepends = unzip
+ depends = sdcc
+ source = http://www.st.com/st-web-ui/static/active/en/st_prod_software_internet/resource/technical/software/firmware/stsw-stm8069.zip
+ md5sums = 74e6fb584ab164b37542db4b0bdc7c57
+
+pkgname = stm8-spl-sdcc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd1276964acc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname="stm8-spl-sdcc"
+pkgver="20150517"
+pkgrel="3"
+pkgdesc="Port of STM8 SPL for SDCC"
+arch=('any')
+url='https://github.com/gicking/SPL_2.2.0_SDCC_patch'
+depends=('sdcc')
+makedepends=('git' 'wget' 'patch' 'unzip')
+source=('http://www.st.com/st-web-ui/static/active/en/st_prod_software_internet/resource/technical/software/firmware/stsw-stm8069.zip')
+md5sums=('74e6fb584ab164b37542db4b0bdc7c57')
+license=('custom')
+
+build() {
+ cd "${srcdir}"
+ git clone https://github.com/gicking/SPL_2.2.0_SDCC_patch
+ cd STM8S_StdPeriph_Lib
+ patch -p1 < ../SPL_2.2.0_SDCC_patch/STM8_SPL_v2.2.0_SDCC.patch
+ sed '/stm8s_it\.h/d' Libraries/STM8S_StdPeriph_Driver/inc/stm8s.h > stm8s.h
+ mv stm8s.h Libraries/STM8S_StdPeriph_Driver/inc/stm8s.h
+}
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/share/sdcc/include/stm8"
+ cp -v STM8S_StdPeriph_Lib/Libraries/STM8S_StdPeriph_Driver/inc/*.h "${pkgdir}/usr/share/sdcc/include/stm8/"
+ cp -v STM8S_StdPeriph_Lib/Project/STM8S_StdPeriph_Template/stm8s_conf.h "${pkgdir}/usr/share/sdcc/include/stm8/"
+ mkdir -p "${pkgdir}/usr/share/sdcc/lib/src/stm8"
+ cp -v STM8S_StdPeriph_Lib/Libraries/STM8S_StdPeriph_Driver/src/*.c "${pkgdir}/usr/share/sdcc/lib/src/stm8/"
+} \ No newline at end of file