summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2020-06-16 14:33:53 +0000
committerBalló György2020-06-16 14:33:53 +0000
commitf21eb39e13a443f8a41dfb5827a5ddb49b5d0f71 (patch)
tree4c020391e371bb81c433a96ff359c7b75bb55d9d
parent55bdce715359e9ea267e36b3678ebc64b0aca3e8 (diff)
downloadaur-stopmotion.tar.gz
Update the package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD55
-rw-r--r--README11
3 files changed, 36 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9424152b2f5d..059b8b15c37d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = stopmotion
pkgdesc = Stop motion animation creation program
- pkgver = 0.8.2
+ pkgver = 0.8.5
pkgrel = 1
- url = http://linuxstopmotion.org/index.html
- arch = i686
+ url = http://linuxstopmotion.org/
arch = x86_64
- license = GPL
+ license = GPL2
makedepends = git
- makedepends = libtar
- depends = qt4
- depends = sdl_image
- depends = libxml2
- depends = libvorbis
- conflicts = linuxstopmotion-git
- source = linuxstopmotion::git+http://git.code.sf.net/p/linuxstopmotion/code#tag=0.8.2
- md5sums = SKIP
+ makedepends = qt5-tools
+ depends = hicolor-icon-theme
+ depends = libtar
+ depends = qt5-multimedia
+ source = linuxstopmotion::git+https://git.code.sf.net/p/linuxstopmotion/code#tag=ed010826d9ae7668d5d477c47a10e4fb1b92ecf8
+ sha256sums = SKIP
pkgname = stopmotion
diff --git a/PKGBUILD b/PKGBUILD
index b0915187e4f2..794b29620fc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,40 @@
-# Maintainer: Mark Grimes <mgrimes at peculier dot com>
+# Contributor: Mark Grimes <mgrimes at peculier dot com>
# Contributor: Tom Vincent <http://tlvince.com/contact/>
# Contributor: macxcool
-# https://github.com/mvgrimes/aur-stopmotion
pkgname=stopmotion
_realname=linuxstopmotion
-pkgver=0.8.2
+pkgver=0.8.5
pkgrel=1
-arch=('i686' 'x86_64')
+arch=(x86_64)
pkgdesc="Stop motion animation creation program"
-url="http://linuxstopmotion.org/index.html"
-license=('GPL')
-makedepends=('pkgconfig')
-depends=('qt4' 'sdl_image' 'libxml2' 'libvorbis')
-# 'inotify-tools'
-makedepends=('git' 'libtar')
-conflicts=('linuxstopmotion-git')
-source=($_realname::git+http://git.code.sf.net/p/$_realname/code#tag=$pkgver)
-# add-unistd.patch)
-md5sums=('SKIP')
+url="http://linuxstopmotion.org/"
+license=(GPL2)
+depends=(hicolor-icon-theme libtar qt5-multimedia)
+makedepends=(git qt5-tools)
+_commit=ed010826d9ae7668d5d477c47a10e4fb1b92ecf8 # tags/0.8.5
+source=($_realname::git+https://git.code.sf.net/p/$_realname/code#tag=$_commit)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_realname
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd $_realname
+ sed -i 's|/share/icons|/share/icons/hicolor/scalable/apps/|' stopmotion.pro
+}
build() {
- cd "$srcdir/$_realname"
- lrelease-qt4 stopmotion.pro
- qmake-qt4 PREFIX=/usr stopmotion.pro
- sed -i '/^LIBS/s|$| -lX11|' Makefile
- make
+ cd $_realname
+ qmake PREFIX=/usr stopmotion.pro
+ make
}
package() {
- cd "$srcdir/$_realname"
- sed -e 's/install_desktop install_dummy/install_desktop/' -i Makefile.Release
- make INSTALL_ROOT="$pkgdir" install
- install -D -m644 stopmotion.desktop "$pkgdir"/usr/share/applications/stopmotion.desktop
- install -D -m644 graphics/stopmotion.png "$pkgdir"/usr/share/pixmaps/stopmotion.png
- install -D -m644 stopmotion.mime "$pkgdir"/usr/share/mime-info/stopmotion.mime
- install -D -m644 stopmotion.1 "$pkgdir"/usr/share/man/man1/stopmotion.1
- gzip "$pkgdir"/usr/share/man/man1/stopmotion.1
+ cd $_realname
+ make INSTALL_ROOT="$pkgdir" install
+ install -Dm644 stopmotion.mime "$pkgdir"/usr/share/mime-info/stopmotion.mime
+ install -Dm644 stopmotion.1 "$pkgdir"/usr/share/man/man1/stopmotion.1
}
-
diff --git a/README b/README
deleted file mode 100644
index 99f9ec5cbaa1..000000000000
--- a/README
+++ /dev/null
@@ -1,11 +0,0 @@
-This is a package of the stopmotion project for Arch Linux.
-
-Stopmotion is a free application for creating stop-motion animation movies. The
-users will be able to create stop-motions from pictures imported from a camera
-or from the harddrive, add sound effects and export the animation to different
-video formats such as mpeg or avi.
-
- http://linuxstopmotion.org/
-
- (originally http://stopmotion.bjoernen.com/)
-