summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrozap2019-09-05 02:57:02 -0500
committercyrozap2019-09-05 02:57:02 -0500
commit23346b33ecd138fcfe5519d8f1b893a565f7f6ff (patch)
treee2f6ed9fa42f51cb024ba8e48d23aa84324be278
parent410342e8e893c74b205b70f9a1ab5f6de8083b01 (diff)
downloadaur-stp.tar.gz
Update to version 2.3.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--cmake-git.patch17
-rw-r--r--mandir.patch11
4 files changed, 33 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4b302a2b891..eaa149922446 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Apr 23 23:55:27 UTC 2016
pkgbase = stp
pkgdesc = Simple Theorem Prover
- pkgver = 2.1.2
+ pkgver = 2.3.3
pkgrel = 1
url = https://stp.github.io/
arch = i686
@@ -12,12 +10,14 @@ pkgbase = stp
makedepends = git
depends = bison
depends = boost
+ depends = cryptominisat5
depends = flex
depends = minisat-git
- source = https://github.com/stp/stp/archive/2.1.2.tar.gz
- source = cmake-git.patch
- sha256sums = d7f118324a534cfa33cabe7302e717f960a3d29e01c5cabc9232d21683f0085d
- sha256sums = cedc57c9e375b145dcd9f3586505477737315194e260de0f689b7715b2088312
+ depends = python2
+ source = https://github.com/stp/stp/archive/2.3.3.tar.gz
+ source = mandir.patch
+ sha256sums = ea6115c0fc11312c797a4b7c4db8734afcfce4908d078f386616189e01b4fffa
+ sha256sums = 4c09301c5a36cd89845a7177e1215008f8bbb23fa6f3c6cc941006825e28c327
pkgname = stp
diff --git a/PKGBUILD b/PKGBUILD
index 8bb6b8ac1a1b..78a55182bc44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,37 @@
# Maintainer: Forest Crossman <cyrozap at gmail dot com>
pkgname=stp
-pkgver=2.1.2
+pkgver=2.3.3
pkgrel=1
pkgdesc="Simple Theorem Prover"
arch=('i686' 'x86_64')
url="https://stp.github.io/"
license=('MIT')
-depends=('bison' 'boost' 'flex' 'minisat-git')
+depends=('bison' 'boost' 'cryptominisat5' 'flex' 'minisat-git' 'python2')
makedepends=('cmake' 'git')
source=("https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
- 'cmake-git.patch')
-sha256sums=('d7f118324a534cfa33cabe7302e717f960a3d29e01c5cabc9232d21683f0085d'
- 'cedc57c9e375b145dcd9f3586505477737315194e260de0f689b7715b2088312')
+ 'mandir.patch')
+sha256sums=('ea6115c0fc11312c797a4b7c4db8734afcfce4908d078f386616189e01b4fffa'
+ '4c09301c5a36cd89845a7177e1215008f8bbb23fa6f3c6cc941006825e28c327')
prepare() {
- cd "$srcdir"
+ cd "$srcdir/$pkgname-$pkgver"
- # Since we're installing from a release archive, searching for a Git
- # directory can cause the build to fail.
- patch -p1 < cmake-git.patch
+ # Correct the destination for man documentation.
+ patch < "$srcdir/mandir.patch"
}
build() {
cd "$srcdir/$pkgname-$pkgver"
+
mkdir -p build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_PYTHON_INTERFACE=ON \
+ ..
make
}
diff --git a/cmake-git.patch b/cmake-git.patch
deleted file mode 100644
index 2b86203720df..000000000000
--- a/cmake-git.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/stp-2.1.2/CMakeLists.txt 2015-10-28 19:35:49.000000000 -0400
-+++ src/stp-2.1.2/CMakeLists.txt 2016-04-23 19:34:26.720530911 -0400
-@@ -260,14 +260,6 @@
- PARENT_SCOPE)
- endfunction()
-
--find_program (GIT_EXECUTABLE git)
--if (GIT_EXECUTABLE)
-- include(GetGitRevisionDescription)
-- get_git_head_revision(GIT_REFSPEC GIT_SHA)
-- MESSAGE(STATUS "GIT hash found: ${GIT_SHA}")
--else()
-- set(GIT_SHA "GIT-hash-notfound")
--endif()
- set(STP_FULL_VERSION "2.1.2")
-
- string(REPLACE "." ";" STP_FULL_VERSION_LIST ${STP_FULL_VERSION})
diff --git a/mandir.patch b/mandir.patch
new file mode 100644
index 000000000000..5a4f513ea594
--- /dev/null
+++ b/mandir.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt 2019-03-02 08:26:01.000000000 -0600
++++ CMakeLists.txt 2019-09-05 02:32:58.324454246 -0500
+@@ -487,7 +487,7 @@
+
+ INSTALL(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/stp.1
+- DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
++ DESTINATION ${CMAKE_INSTALL_FULL_MANDIR}/man1)
+ message(STATUS "Manpage will be created and installed")
+ endif()
+ else()