summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxeruf2021-09-27 14:19:12 +0200
committerxeruf2021-09-27 14:19:12 +0200
commit579244a26cd06372375eed3826a240b33bdd8237 (patch)
treea5ea9501710a84a93ae4f9048f88ae48a76e2add
parent2972f80b6707eafff648eb5b23c6e815b70daf17 (diff)
downloadaur-579244a26cd06372375eed3826a240b33bdd8237.tar.gz
Create git version of xeruf fork
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5e32425b56a..bde8833a294e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-pkgbase = stretchly-git
- pkgdesc = The break time reminder app
- pkgver = 960.86c901e
+pkgbase = stretchly-xeruf-git
+ pkgdesc = The break time reminder app, hardened
+ pkgver = 986.1312677
pkgrel = 1
- url = https://github.com/hovancik/stretchly/
+ url = https://github.com/xeruf/stretchly
arch = any
license = BSD
makedepends = git
@@ -24,10 +24,9 @@ pkgbase = stretchly-git
depends = libnotify
depends = libappindicator-gtk3
depends = electron
+ optdepends = libxss
provides = stretchly
- conflicts = stretchly
- conflicts = stretchly-bin
- source = git+https://github.com/hovancik/stretchly.git
+ source = git+https://github.com/xeruf/stretchly.git
sha256sums = SKIP
-pkgname = stretchly-git
+pkgname = stretchly-xeruf-git
diff --git a/PKGBUILD b/PKGBUILD
index 4a3219c01a9f..c31e88bb2ec0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
-# Maintainer: Luke Arms <luke@arms.to>
+# Maintainer: xerus <27jf at pm dot me>
-pkgname=stretchly-git
-_pkgname=${pkgname%-git}
-pkgver=960.86c901e
+_pkgname=stretchly
+pkgname=${_pkgname}-xeruf-git
+pkgver=986.1312677
pkgrel=1
-pkgdesc="The break time reminder app"
+pkgdesc="The break time reminder app, hardened"
arch=('any')
-url="https://github.com/hovancik/stretchly/"
+url="https://github.com/xeruf/stretchly"
license=('BSD')
depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3' 'electron')
makedepends=('git' 'nvm' 'jq' 'python')
+optdepends=('libxss')
provides=("$_pkgname")
-conflicts=("$_pkgname" "${_pkgname}-bin")
-source=("git+https://github.com/hovancik/stretchly.git")
+source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- printf '%s.%s' \
- "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf '%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
_ensure_local_nvm() {