summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordanitool2015-12-20 16:02:41 +0100
committerdanitool2015-12-20 16:02:41 +0100
commit1dab826cfc7907f3263693350027f7108a2d4dd4 (patch)
treed06a3b7ea85e518aa86103606a5ad48ca74afc3c
parentbaa290ac3deb3ca223989184bb448909d3f1ac86 (diff)
downloadaur-stupid-ftpd.tar.gz
rid off warnings
-rw-r--r--.SRCINFO6
-rw-r--r--03-ridoff-warnings.patch95
-rw-r--r--PKGBUILD9
3 files changed, 105 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b62f88c521f..9b49b0e0f529 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Dec 20 02:05:36 UTC 2015
+# Sun Dec 20 15:01:22 UTC 2015
pkgbase = stupid-ftpd
pkgdesc = stupid-ftpd is an ftp server, which provides a normal ftp-daemon functionality and a command-line mode. It has got a /etc/passwdindependent user database which allows many variations of permissions. The server is easy to configure and very flexible
pkgver = 1.5beta
- pkgrel = 3
+ pkgrel = 4
url = http://stupid-ftpd.sourceforge.net/
install = post_install
arch = i686
@@ -13,10 +13,12 @@ pkgbase = stupid-ftpd
source = stupid-ftpd.service
source = 01-fixes.patch
source = 02-cwd-interactive.patch
+ source = 03-ridoff-warnings.patch
md5sums = be5700570bc38376515d33595e416663
md5sums = fc0a7a5f143ef657d8d495a030fa8c20
md5sums = 915b029020af010d9c3072b6a4d17700
md5sums = 93b8aa760d599e7124c78ad858b5a8e8
+ md5sums = 157beac3d7130cd11aaf6a61288c9607
pkgname = stupid-ftpd
diff --git a/03-ridoff-warnings.patch b/03-ridoff-warnings.patch
new file mode 100644
index 000000000000..7d0cb82ca70e
--- /dev/null
+++ b/03-ridoff-warnings.patch
@@ -0,0 +1,95 @@
+--- ftpcommand.c
++++ ftpcommand.c
+@@ -261,7 +261,8 @@
+
+ int waitaccept(int nr)
+ {
+- int socksize,soc;
++ unsigned int socksize;
++ int soc;
+ struct sockaddr_in sai;
+
+ signal(SIGALRM,childtimeout);
+@@ -386,6 +387,7 @@
+ }
+
+ hp=gethostbyaddr((char *)&addr,sizeof(addr),AF_INET);
++ printf("Hostname:%s\n", hp->h_name);
+
+ #ifdef DEBUG
+ fprintf(stderr,"Making connection to: %s:%d\n",cmd,pchild[nr]->dataport);
+@@ -438,7 +440,10 @@
+ char allowed[MAXPATHLEN+4],path[MAXPATHLEN+4];
+ struct stat buf;
+ /* fixed bug by PaN */
+- char myparam[MAXPATHLEN+4], myparamtmp[MAXPATHLEN+4];
++ char myparam[MAXPATHLEN+4];
++#ifdef REMOVE
++ char myparamtmp[MAXPATHLEN+4];
++#endif
+ int i;
+
+ /* Rule for checking path, added by Chen-I */
+@@ -555,6 +560,7 @@
+ if ((int)addr==-1) return RET_501;
+
+ hp=gethostbyaddr((char *)&addr,sizeof(addr),AF_INET);
++ printf("Hostname:%s\n", hp->h_name);
+
+ if ((soc=socket(AF_INET,SOCK_STREAM,0))<0) return RET_501;
+ socksize=sizeof(struct sockaddr_in);
+@@ -731,6 +737,7 @@
+ if ((int)addr==-1) return 1;
+
+ hp=gethostbyaddr((char *)&addr,sizeof(addr),AF_INET);
++ printf("Hostname:%s\n", hp->h_name);
+
+ #ifdef DEBUG
+ fprintf(stderr,"Making connection to: %s:%d\n",cmd,pchild[nr]->dataport);
+@@ -1081,7 +1088,10 @@
+ {
+ char path[1024];
+ /* fixed bug by PaN */
+- char myparam[MAXPATHLEN+4], myparamtmp[MAXPATHLEN+4];
++ char myparam[MAXPATHLEN+4];
++#ifdef REMOVE
++ myparamtmp[MAXPATHLEN+4];
++#endif
+ int i;
+
+ #ifdef REMOVE
+@@ -1139,7 +1149,10 @@
+ {
+ char path[2048];
+ /* fixed bug by PaN */
+- char myparam[MAXPATHLEN+4], myparamtmp[MAXPATHLEN+4];
++ char myparam[MAXPATHLEN+4];
++#ifdef REMOVE
++ myparamtmp[MAXPATHLEN+4];
++#endif
+ int i;
+
+ #ifdef REMOVE
+--- ftpdconfig.c
++++ ftpdconfig.c
+@@ -464,7 +464,7 @@
+
+ static unsigned char myip[4];
+ struct sockaddr_in sa;
+- int size;
++ socklen_t size;
+
+ size=sizeof(struct sockaddr_in);
+ memset(myip,0,sizeof(myip));
+--- stupid-ftpd.c
++++ stupid-ftpd.c
+@@ -78,7 +78,8 @@
+ }
+
+ void init_login(void) {
+- int nr,sock,sock_size;
++ int nr,sock;
++ unsigned int sock_size;
+ char buffer[128];
+ struct sockaddr_in sa;
+ struct hostent *hp;
diff --git a/PKGBUILD b/PKGBUILD
index 2b19708f1bbc..2f8bcea7e12d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=stupid-ftpd
pkgver=1.5beta
-pkgrel=3
+pkgrel=4
pkgdesc="stupid-ftpd is an ftp server, which provides a normal ftp-daemon functionality and a command-line mode. It has got a /etc/passwdindependent user database which allows many variations of permissions. The server is easy to configure and very flexible"
arch=('i686' 'x86_64')
url="http://stupid-ftpd.sourceforge.net/"
@@ -11,17 +11,20 @@ license=('GPL')
source=("http://downloads.sourceforge.net/project/stupid-ftpd/stupid-ftpd/V1_5beta/$pkgname-$pkgver.tar.gz"
'stupid-ftpd.service'
'01-fixes.patch'
- '02-cwd-interactive.patch')
+ '02-cwd-interactive.patch'
+ '03-ridoff-warnings.patch')
md5sums=('be5700570bc38376515d33595e416663'
'fc0a7a5f143ef657d8d495a030fa8c20'
'915b029020af010d9c3072b6a4d17700'
- '93b8aa760d599e7124c78ad858b5a8e8')
+ '93b8aa760d599e7124c78ad858b5a8e8'
+ '157beac3d7130cd11aaf6a61288c9607')
install=post_install
build() {
cd $srcdir/$pkgname
patch -p0 -i ${srcdir}/01-fixes.patch
patch -p0 -i ${srcdir}/02-cwd-interactive.patch
+ patch -p0 -i ${srcdir}/03-ridoff-warnings.patch
make || return 1
}