summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWhyme Lyu2022-06-29 00:52:37 +0800
committerWhyme Lyu2022-06-29 00:52:37 +0800
commit21c7c56e6110343a729574033672338b818c01f0 (patch)
treef7cac0cc6c00e5004b21ec7f7c82eb9229d455fb
parent723a0c8d80bf9954328868c1a1c737eb1797bb8f (diff)
downloadaur-sunloginremote.tar.gz
Upgrade sunloginremote to 5.5.0.45114
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c29374162f46..99d351fec563 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sunloginremote
pkgdesc = Proprietary software that remotely controls mobile devices, Windows, Mac, Linux and other systems. Enterprise edition.
- pkgver = 5.1.0.36963
+ pkgver = 5.5.0.45114
pkgrel = 1
url = https://sunlogin.oray.com/product/support
install = sunloginremote.install
@@ -9,11 +9,11 @@ pkgbase = sunloginremote
depends = libappindicator-gtk3
depends = sh
depends = wqy-zenhei
- source = https://down.oray.com/sunlogin/linux/sunloginremote-5.1.0.36963-amd64.deb
+ source = https://down.oray.com/sunlogin/linux/sunloginremote-5.5.0.45114-amd64.deb
source = shim.sh
source = tmpfiles.conf
source = license.html
- b2sums = 26d65d8ca66ab6bb78c5c9d5715dda668293e469c9feb9ddacc74f1d73d3025b60c3e137a45dc45f098b6bcefe3b87538b3397825de5553f41d4201e12b7befe
+ b2sums = ce5e29dcf218048d78033ed8f18bb75da82a5684f8773167a82f6b118572b15a0344913c2de0b1693c61f136c066e39e68541ebfbb65769e7105552336a9fc39
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index afe8d5f3c11f..3a3f18fe0220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# zhullyb <zhullyb at outlook dot com>
pkgname=sunloginremote
-pkgver=5.1.0.36963
+pkgver=5.5.0.45114
pkgrel=1
pkgdesc='Proprietary software that remotely controls mobile devices, Windows, Mac, Linux and other systems. Enterprise edition.'
arch=(x86_64)
@@ -22,7 +22,7 @@ source=("https://down.oray.com/sunlogin/linux/${pkgname}-${pkgver}-amd64.deb"
shim.sh
tmpfiles.conf
license.html)
-b2sums=('26d65d8ca66ab6bb78c5c9d5715dda668293e469c9feb9ddacc74f1d73d3025b60c3e137a45dc45f098b6bcefe3b87538b3397825de5553f41d4201e12b7befe'
+b2sums=('ce5e29dcf218048d78033ed8f18bb75da82a5684f8773167a82f6b118572b15a0344913c2de0b1693c61f136c066e39e68541ebfbb65769e7105552336a9fc39'
'SKIP'
'SKIP'
'SKIP')
@@ -38,7 +38,7 @@ prepare() {
}
_install() {
- find "usr/local/$pkgname/$1" -type f -exec \
+ find "opt/$pkgname/$1" -type f -exec \
install -Dm$2 {} -t "${pkgdir}/opt/$pkgname/$1" \;
}
@@ -50,19 +50,9 @@ build() {
test -r "$desktop_file"
# fix path
sed -i -e "
- s#Exec=/usr/local/$pkgname/bin/#Exec=/usr/bin/#
- s#Icon=/usr/local/$pkgname/res/icon/sunlogin_remote.png#Icon=$pkgname#
+ s#Exec=/opt/$pkgname/bin/#Exec=/usr/bin/#
" "$desktop_file"
- binfile="usr/local/$pkgname/bin/$pkgname"
- test -x "$binfile"
- # ugly hack
- sed -i -e "
- s#/usr/local/sunloginremote/res\x0#/opt/sunloginremote/res\x0\x0\x0\x0\x0\x0\x0#g
- s#/usr/local/sunloginremote/res/icon/%s.ico\x0#/opt/sunloginremote/res/icon/%s.ico\x0\x0\x0\x0\x0\x0\x0#g
- s#/usr/local/sunloginremote\x0#/opt/sunloginremote\x0\x0\x0\x0\x0\x0\x0#g
- " "$binfile"
-
popd
}
@@ -78,15 +68,17 @@ package() {
mkdir -m=755 "$pkgdir/opt/$pkgname/res/font"
ln -s ../../../../usr/share/fonts/wenquanyi/wqy-zenhei/wqy-zenhei.ttc \
"$pkgdir/opt/$pkgname/res/font/"
- install -Dm644 "usr/local/$pkgname/res/DRBELL.WAV" \
+
+ install -Dm644 "opt/$pkgname/res/DRBELL.WAV" \
-t "$pkgdir/opt/$pkgname/res"
+
# desktop entry
install -Dm644 usr/share/applications/$pkgname.desktop \
-t "$pkgdir/usr/share/applications"
- # icon
- install -Dm644 usr/local/$pkgname/res/icon/sunlogin_remote.png \
+ # icon ## TODO: use symlink instead
+ install -Dm644 opt/$pkgname/res/icon/sunlogin_remote.png \
"$pkgdir/usr/share/pixmaps/$pkgname.png"
# # license