summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2019-11-12 17:58:10 +0100
committerDavid Runge2019-11-12 17:58:10 +0100
commitc825f23a8acc2a78b2c7cf555fadb966399cb5b4 (patch)
tree74ccb4d520a81de5fdc610d7537be4034ca676d8
parent1db348cc64f95194282f1416c28abd118a9b9a2f (diff)
downloadaur-c825f23a8acc2a78b2c7cf555fadb966399cb5b4.tar.gz
PKGBUILD: Updating maintainer info. Adding all direct library dependencies. Adding libscsynth.so to provides.
Adding upstream patch to fix build issues with boost 1.71.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7153a7a0e64b..b32567d6b21a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = supercollider-git
pkgdesc = Environment and programming language for real time audio synthesis and algorithmic composition
- pkgver = 3.10.2.r399.g63783aeca0
+ pkgver = 3.10.3.r483.g36cbdde009
pkgrel = 1
url = https://supercollider.github.io/
arch = i686
@@ -15,20 +15,31 @@ pkgbase = supercollider-git
makedepends = git
makedepends = link
makedepends = qt5-tools
+ depends = alsa-lib
+ depends = avahi
depends = boost-libs
depends = desktop-file-utils
depends = fftw
+ depends = gcc-libs
+ depends = glibc
depends = jack
+ depends = libsndfile
+ depends = libx11
+ depends = qt5-base
depends = qt5-svg
depends = qt5-webengine
depends = qt5-websockets
+ depends = readline
+ depends = systemd-libs
depends = yaml-cpp
optdepends = emacs: emacs interface
optdepends = gedit: gedit interface
optdepends = sc3-plugins: additional extension plugins for scsynth
+ provides = libscsynth.so
provides = supercollider
conflicts = supercollider
source = git+https://github.com/supercollider/supercollider.git#branch=develop
+ source = supercollider-git-boost1.71.patch::https://github.com/supercollider/supercollider/pull/4612.patch
source = supercollider-git-devendor-ableton-link.patch
source = git+https://github.com/ableton/link.git
source = git+https://github.com/supercollider/scel.git
@@ -39,6 +50,7 @@ pkgbase = supercollider-git
source = git+https://github.com/timblechmann/nova-simd.git
source = git+https://github.com/timblechmann/nova-tt.git
sha512sums = SKIP
+ sha512sums = 005d241b797083dc031dda7f192013b69887c84db6b2616176605abafc1633c06a46a58b8ad1581d4cce0650fbc1f6d479b8992dbe4bdbf5ceace77fdccbdca8
sha512sums = 8aa14c7bf94b69f0ffa5b6f348544c3df72083d9f39cdf509efee3997e2e93cde2a3a8f6d6a149b3fd431843fec630d22c31c0f0332f2a1fff24c79ca4c16a00
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3e88ce89f4a9..5e585abc7e8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-# Maintainer: David Runge <dave@sleepmap.de>
+# Maintainer: David Runge <dvzrv@archlinux.org>
pkgname=supercollider-git
_name="supercollider"
-pkgver=3.10.2.r399.g63783aeca0
+pkgver=3.10.3.r483.g36cbdde009
pkgrel=1
pkgdesc="Environment and programming language for real time audio synthesis and algorithmic composition"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://supercollider.github.io/"
license=('GPL3')
-depends=('boost-libs' 'desktop-file-utils' 'fftw' 'jack' 'qt5-svg'
-'qt5-webengine' 'qt5-websockets' 'yaml-cpp')
+depends=('alsa-lib' 'avahi' 'boost-libs' 'desktop-file-utils' 'fftw' 'gcc-libs'
+'glibc' 'jack' 'libsndfile' 'libx11' 'qt5-base' 'qt5-svg' 'qt5-webengine'
+'qt5-websockets' 'readline' 'systemd-libs' 'yaml-cpp')
makedepends=('boost' 'cmake' 'emacs' 'git' 'link' 'qt5-tools')
checkdepends=('xorg-server-xvfb')
optdepends=('emacs: emacs interface'
'gedit: gedit interface'
'sc3-plugins: additional extension plugins for scsynth')
conflicts=('supercollider')
-provides=('supercollider')
+provides=('libscsynth.so' 'supercollider')
source=("git+https://github.com/${_name}/${_name}.git#branch=develop"
+ "${pkgname}-boost1.71.patch::https://github.com/supercollider/supercollider/pull/4612.patch"
"${pkgname}-devendor-ableton-link.patch"
"git+https://github.com/ableton/link.git"
"git+https://github.com/${_name}/scel.git"
@@ -28,6 +30,7 @@ source=("git+https://github.com/${_name}/${_name}.git#branch=develop"
"git+https://github.com/timblechmann/nova-simd.git"
"git+https://github.com/timblechmann/nova-tt.git")
sha512sums=('SKIP'
+ '005d241b797083dc031dda7f192013b69887c84db6b2616176605abafc1633c06a46a58b8ad1581d4cce0650fbc1f6d479b8992dbe4bdbf5ceace77fdccbdca8'
'8aa14c7bf94b69f0ffa5b6f348544c3df72083d9f39cdf509efee3997e2e93cde2a3a8f6d6a149b3fd431843fec630d22c31c0f0332f2a1fff24c79ca4c16a00'
'SKIP'
'SKIP'
@@ -40,7 +43,7 @@ sha512sums=('SKIP'
pkgver() {
cd "${_name}"
- git describe --long --tags | sed 's/Version-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --match 'Version-*' --tags | sed 's/Version-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -57,6 +60,7 @@ prepare() {
git config submodule.external_libraries/link.url "${srcdir}/link"
git submodule update
patch -Np1 -i ../"${pkgname}-devendor-ableton-link.patch"
+ patch -Np1 -i ../"${pkgname}-boost1.71.patch"
mkdir -p build
}