summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMads Kjeldgaard2022-03-16 12:40:26 +0100
committerMads Kjeldgaard2022-03-16 12:40:26 +0100
commit5c919471ad1838e40ef684e6f4abff9c1c4e5e84 (patch)
tree34fd1c98d19544e326bc8ee26b6b1a26255e853a
downloadaur-supercollider-headless-git.tar.gz
first
-rw-r--r--.SRCINFO68
-rw-r--r--PKGBUILD122
-rw-r--r--supercollider-cxxflags.patch11
3 files changed, 201 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c397052ae409
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,68 @@
+pkgbase = supercollider-headless-git
+ pkgdesc = Headless build of SuperCollider (no QT)
+ pkgver = 3.12.2.r235.gec2dedfda8
+ pkgrel = 1
+ url = https://supercollider.github.io/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ checkdepends = xorg-server-xvfb
+ makedepends = abletonlink
+ makedepends = alsa-lib
+ makedepends = avahi
+ makedepends = boost
+ makedepends = cmake
+ makedepends = emacs
+ makedepends = fftw
+ makedepends = git
+ makedepends = jack
+ makedepends = libsndfile
+ makedepends = readline
+ makedepends = systemd-libs
+ makedepends = yaml-cpp
+ depends = gcc-libs
+ depends = glibc
+ depends = libx11
+ optdepends = emacs: emacs interface
+ optdepends = gedit: gedit interface
+ optdepends = sc3-plugins: additional extension plugins for scsynth
+ provides = supercollider
+ conflicts = supercollider
+ source = git+https://github.com/supercollider/supercollider.git#branch=develop
+ source = git+https://github.com/ableton/link.git
+ source = git+https://github.com/supercollider/scel.git
+ source = git+https://github.com/supercollider/scvim.git
+ source = git+https://github.com/supercollider/hidapi.git
+ source = git+https://github.com/supercollider/portaudio.git
+ source = git+https://github.com/supercollider/yaml-cpp.git
+ source = git+https://github.com/timblechmann/nova-simd.git
+ source = git+https://github.com/timblechmann/nova-tt.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = supercollider-headless-git
+ depends = gcc-libs
+ depends = glibc
+ depends = libx11
+ depends = libasound.so
+ depends = libavahi-common.so
+ depends = libavahi-client.so
+ depends = libboost_filesystem.so
+ depends = libboost_program_options.so
+ depends = libboost_regex.so
+ depends = libboost_thread.so
+ depends = libfftw3f.so
+ depends = libjack.so
+ depends = libreadline.so
+ depends = libsndfile.so
+ depends = libudev.so
+ depends = libyaml-cpp.so
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59bb9e84e47b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,122 @@
+# Maintainer: Mads Kjeldgaard <mail@madskjeldgaard.dk>
+
+pkgname=supercollider-headless-git
+_name="supercollider"
+pkgver=3.12.2.r235.gec2dedfda8
+pkgrel=1
+pkgdesc="Headless build of SuperCollider (no QT)"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://supercollider.github.io/"
+license=('GPL3')
+depends=('gcc-libs' 'glibc' 'libx11' )
+makedepends=('abletonlink' 'alsa-lib' 'avahi' 'boost' 'cmake' 'emacs' 'fftw'
+'git' 'jack' 'libsndfile' 'readline' 'systemd-libs' 'yaml-cpp')
+checkdepends=('xorg-server-xvfb')
+optdepends=('emacs: emacs interface'
+ 'gedit: gedit interface'
+ 'sc3-plugins: additional extension plugins for scsynth')
+conflicts=('supercollider')
+provides=('supercollider')
+source=("git+https://github.com/${_name}/${_name}.git#branch=develop"
+ "git+https://github.com/ableton/link.git"
+ "git+https://github.com/${_name}/scel.git"
+ "git+https://github.com/${_name}/scvim.git"
+ "git+https://github.com/${_name}/hidapi.git"
+ "git+https://github.com/${_name}/portaudio.git"
+ "git+https://github.com/${_name}/yaml-cpp.git"
+ "git+https://github.com/timblechmann/nova-simd.git"
+ "git+https://github.com/timblechmann/nova-tt.git")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${_name}"
+ git describe --long --match 'Version-*' --tags | sed 's/Version-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_name}"
+ git submodule init
+ git config submodule.editors/sc-el.url "${srcdir}/scel"
+ git config submodule.editors/scvim.url "${srcdir}/scvim"
+ git config submodule.external_libraries/nova-simd.url "${srcdir}/nova-simd"
+ git config submodule.external_libraries/nova-tt.url "${srcdir}/nova-tt"
+ git config submodule.external_libraries/hidapi.url "${srcdir}/hidapi"
+ git config submodule.external_libraries/portaudio_sc_org.url "${srcdir}/portaudio"
+ git config submodule.external_libraries/portaudio_sc_org.branch "${_name}"
+ git config submodule.external_libraries/yaml-cpp.url "${srcdir}/yaml-cpp"
+ git config submodule.external_libraries/link.url "${srcdir}/link"
+ git submodule update
+}
+
+build() {
+ cd "${_name}"
+ _carch="$(uname -m)"
+ _cmake_args=""
+ echo "$_carch architecture detected."
+ case "$_carch" in
+ "armv6l")
+ export CFLAGS='-march=armv6 -mfpu=vfp -mfloat-abi=hard'
+ export CXXFLAGS='-march=armv6 -mfpu=vfp -mfloat-abi=hard'
+ _cmake_args="-DSSE=OFF \
+ -DSSE2=OFF \
+ -DSUPERNOVA=OFF \
+ -DNATIVE=OFF \
+ -DSC_QT=OFF \
+ -DSC_ED=OFF \
+ -DSC_IDE=OFF"
+ ;;
+ "armv7l")
+ export CFLAGS='-march=armv7-a -mtune=cortex-a8 -mfloat-abi=hard -mfpu=neon'
+ export CXXFLAGS='-march=armv7-a -mtune=cortex-a8 -mfloat-abi=hard -mfpu=neon'
+ _cmake_args="-DSSE=OFF \
+ -DSSE2=OFF \
+ -DSUPERNOVA=OFF \
+ -DNATIVE=OFF \
+ -DSC_QT=OFF \
+ -DSC_ED=OFF \
+ -DSC_IDE=OFF"
+ ;;
+ *)
+ export CFLAGS+=" -DNDEBUG"
+ export CXXFLAGS+=" -DNDEBUG"
+ cmake -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DFORTIFY=ON \
+ -DSC_VIM=OFF \
+ -DSC_QT=OFF \
+ -DSC_IDE=OFF \
+ -DSYSTEM_ABLETON_LINK=ON \
+ -DSYSTEM_BOOST=ON \
+ -DSYSTEM_YAMLCPP=ON \
+ ${_cmake_args} \
+ -Wno-dev \
+ -B build \
+ -S .
+ ;;
+ esac
+ make VERBOSE=1 -C build
+}
+
+check() {
+ cd "${_name}"
+ xvfb-run make test ARGS="-VV -d -j1" -C build
+}
+
+package() {
+ depends+=('libasound.so' 'libavahi-common.so' 'libavahi-client.so'
+ 'libboost_filesystem.so' 'libboost_program_options.so' 'libboost_regex.so'
+ 'libboost_thread.so' 'libfftw3f.so' 'libjack.so' 'libreadline.so'
+ 'libsndfile.so' 'libudev.so' 'libyaml-cpp.so')
+ cd "${_name}"
+ make DESTDIR="${pkgdir}/" install -C build
+ install -vDm 644 {AUTHORS,{CHANGELOG,README,README_LINUX}.md} \
+ -t "${pkgdir}/usr/share/doc/${pkgname}/"
+}
diff --git a/supercollider-cxxflags.patch b/supercollider-cxxflags.patch
new file mode 100644
index 000000000000..28f6f81dfb89
--- /dev/null
+++ b/supercollider-cxxflags.patch
@@ -0,0 +1,11 @@
+--- SuperCollider-Source/CMakeLists.txt.orig 2016-10-23 10:21:32.322819928 +0000
++++ SuperCollider-Source/CMakeLists.txt 2016-10-23 10:21:52.259731856 +0000
+@@ -240,7 +240,7 @@
+ if (CMAKE_COMPILER_IS_GNUCXX OR CMAKE_COMPILER_IS_CLANG)
+ if (SSE)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -msse")
+- set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -msse")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse")
+ if(NOT APPLE AND NOT CMAKE_COMPILER_IS_CLANG)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpmath=sse")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mfpmath=sse")