summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Blomstrand2020-10-22 11:48:34 +0200
committerMikael Blomstrand2020-10-22 11:48:34 +0200
commit17fe1ac3c9ddf6f240c752d63f61426162921fd6 (patch)
tree21095d7fae25b9aec191456cc02b9b3119802009
parent83bf30419147034ff6afb1febb10e142abec4dec (diff)
downloadaur-svgbob-git.tar.gz
fix broken PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de63c5f055a1..24a2c76f0613 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = svgbob-git
pkgdesc = Convert your ascii diagram scribbles into happy little SVG
- pkgver = 0.4.1.r328.883aa12
+ pkgver = 0.5.0alpha.8.r389.503f303
pkgrel = 1
url = https://github.com/ivanceras/svgbob
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 2bb686091cc5..fae5b24272c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Mikael Blomstrand <mbloms ÅT kth DÖT se>
+# Maintainer: Mikael Blomstrand <gmail: kmbloms>
pkgname=svgbob-git
-pkgver=0.4.1.r328.883aa12
+pkgver=0.5.0alpha.8.r389.503f303
pkgrel=1
pkgdesc='Convert your ascii diagram scribbles into happy little SVG'
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/svgbob"
- printf "%s.r%s.%s" "$(grep version svgbob_cli/Cargo.toml | sed -e "s/version = \"//" -e "s/\"//")"\
+ printf "%s.r%s.%s" "$(grep '^version = ' svgbob_cli/Cargo.toml | sed -e "s/version = \"//" -e "s/\"//" -e "s/-//")"\
"$(git rev-list --count HEAD)"\
"$(git rev-parse --short HEAD)"
}
@@ -27,6 +27,6 @@ build() {
}
package() {
- install -Dm755 "${srcdir}/svgbob/svgbob_cli/target/release/svgbob" "${pkgdir}/usr/bin/svgbob"
+ install -Dm755 "${srcdir}/svgbob/target/release/svgbob" "${pkgdir}/usr/bin/svgbob"
install -Dm644 "${srcdir}/svgbob/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}