summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-01-15 19:05:40 +0000
committerJonathon Fernyhough2018-01-15 19:05:40 +0000
commit312d470a2a3a76d399c15d9ae4caaf1198f3af03 (patch)
tree20e92779be697ee43bffba31e53f008a9d78faf5
downloadaur-swatchbooker.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a225fb65b50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = swatchbooker
+ pkgdesc = Colour swatch book viewer/convertor/editor
+ pkgver = 0.7.6
+ pkgrel = 1
+ url = http://www.selapa.net/swatchbooker/
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = python2-pyqt4
+ source = swatchbooker-0.7.6.tar.gz::https://github.com/olivierberten/SwatchBooker/archive/0.7.6.tar.gz
+ sha256sums = 8597f3a32d2da16aa79e9b3ebb64383aaba870a26acb11bf7ccae50923639848
+
+pkgname = swatchbooker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4fbb9546f8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jonathon Fernyhough <jonathon at_manjaro_org>
+
+pkgname=swatchbooker
+_pkgname=SwatchBooker
+pkgver=0.7.6
+pkgrel=1
+pkgdesc='Colour swatch book viewer/convertor/editor'
+arch=('any')
+url='http://www.selapa.net/swatchbooker/'
+license=('GPL3')
+depends=('python2' 'python2-pyqt4')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/olivierberten/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('8597f3a32d2da16aa79e9b3ebb64383aaba870a26acb11bf7ccae50923639848')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 ./setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 ./setup.py install -O2 --prefix="${pkgdir}"/usr
+
+ # Tidy
+ rm "${pkgdir}"/usr/bin/swatchbooker_w32_postinst.py
+
+ # Fix up
+ chmod a+x "${pkgdir}"/usr/bin/*
+ for exe in "${pkgdir}"/usr/bin/*; do
+ sed -i '4s|python|python2|' "$exe"
+ done
+}