summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonin Décimo2020-10-23 12:18:57 +0200
committerAntonin Décimo2020-10-23 22:41:23 +0200
commit5508e76470074eaaf6309f14236d00c03c7f93fe (patch)
tree0f4f53448e08f2574642d477a57c9463a83832df
parentc7e90443178d23c6a7c779ec95897649b1452ef4 (diff)
downloadaur-5508e76470074eaaf6309f14236d00c03c7f93fe.tar.gz
Update to parity with community/sway.
-rw-r--r--.SRCINFO37
-rw-r--r--50-systemd-user.conf7
-rw-r--r--PKGBUILD59
3 files changed, 73 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0431292cdf5b..6541fb6aed75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,45 @@
pkgbase = sway-git
- pkgdesc = i3-compatible Wayland compositor
- pkgver = r5942.3f77591b
+ pkgdesc = Tiling Wayland compositor and replacement for the i3 window manager
+ pkgver = r6506.1be66c98
pkgrel = 1
url = https://swaywm.org
arch = i686
arch = x86_64
license = MIT
- makedepends = meson
makedepends = git
+ makedepends = meson
+ makedepends = ninja
makedepends = scdoc
makedepends = wayland-protocols
- makedepends = ninja
+ depends = cairo
+ depends = gdk-pixbuf2
depends = json-c
+ depends = pango
+ depends = polkit
depends = pcre
+ depends = swaybg-git
+ depends = ttf-font
depends = wlroots-git
- depends = cairo
- depends = pango
- depends = gdk-pixbuf2
- depends = pam
depends = xorg-server-xwayland
- depends = swaybg-git
- optdepends = alacritty: Default terminal emulator.
- optdepends = dmenu: Default for launching applications.
- optdepends = i3status: To display system information with a bar.
- optdepends = swayidle-git: Idle management daemon for Sway.
- optdepends = swaylock-git: Screen locker for Sway.
+ optdepends = alacritty: Terminal emulator used by the default config
+ optdepends = dmenu: Application launcher
+ optdepends = grim: Screenshot utility
+ optdepends = i3status: Status line
+ optdepends = mako: Lightweight notification daemon
+ optdepends = slurp: Select a region
+ optdepends = swayidle: Idle management daemon
+ optdepends = swaylock: Screen locker
+ optdepends = wallutils: Timed wallpapers
+ optdepends = waybar: Highly customizable bar
provides = sway
conflicts = sway
options = debug
options = !strip
+ backup = etc/sway/config
source = sway::git+https://github.com/swaywm/sway.git
+ source = 50-systemd-user.conf
sha512sums = SKIP
+ sha512sums = 57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e
pkgname = sway-git
diff --git a/50-systemd-user.conf b/50-systemd-user.conf
new file mode 100644
index 000000000000..72e5dcd98b02
--- /dev/null
+++ b/50-systemd-user.conf
@@ -0,0 +1,7 @@
+# sway does not set DISPLAY/WAYLAND_DISPLAY in the systemd user environment
+# See FS#63021
+# Adapted from xorg's 50-systemd-user.sh, which achieves a similar goal.
+
+exec systemctl --user import-environment DISPLAY WAYLAND_DISPLAY SWAYSOCK
+exec hash dbus-update-activation-environment 2>/dev/null && \
+ dbus-update-activation-environment --systemd DISPLAY WAYLAND_DISPLAY SWAYSOCK
diff --git a/PKGBUILD b/PKGBUILD
index e655a7a86779..8732c134d37b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,49 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
+# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
pkgname=sway-git
_pkgname=sway
-pkgver=r5942.3f77591b
+pkgver=r6506.1be66c98
pkgrel=1
license=("MIT")
-pkgdesc="i3-compatible Wayland compositor"
-makedepends=("meson" "git" "scdoc" "wayland-protocols" "ninja")
+pkgdesc="Tiling Wayland compositor and replacement for the i3 window manager"
+makedepends=(
+ "git"
+ "meson"
+ "ninja"
+ "scdoc"
+ "wayland-protocols"
+)
depends=(
- "json-c" "pcre" "wlroots-git" "cairo" "pango" "gdk-pixbuf2" "pam"
- "xorg-server-xwayland" "swaybg-git"
+ "cairo"
+ "gdk-pixbuf2"
+ "json-c"
+ "pango"
+ "polkit"
+ "pcre"
+ "swaybg-git"
+ "ttf-font"
+ "wlroots-git"
+ "xorg-server-xwayland"
)
optdepends=(
- "alacritty: Default terminal emulator."
- "dmenu: Default for launching applications."
- "i3status: To display system information with a bar."
- "swayidle-git: Idle management daemon for Sway."
- "swaylock-git: Screen locker for Sway."
+ "alacritty: Terminal emulator used by the default config"
+ "dmenu: Application launcher"
+ "grim: Screenshot utility"
+ "i3status: Status line"
+ "mako: Lightweight notification daemon"
+ "slurp: Select a region"
+ "swayidle: Idle management daemon"
+ "swaylock: Screen locker"
+ "wallutils: Timed wallpapers"
+ "waybar: Highly customizable bar"
)
+backup=(etc/sway/config)
arch=("i686" "x86_64")
url="https://swaywm.org"
-source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git")
-sha512sums=('SKIP')
+source=("${pkgname%-*}::git+https://github.com/swaywm/sway.git"
+ 50-systemd-user.conf)
+sha512sums=("SKIP"
+ "57590bc0d14c87289a4a9cd67991c6a841e54244d2a6186b5da5a08e633de2e8631959fa8c77ede211b0a5f315d920f2c1350951a53d6f2e9e81859056cb3c9e")
provides=("sway")
conflicts=("sway")
options=(debug !strip)
@@ -30,10 +53,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$_pkgname"
-}
-
build() {
cd "$_pkgname"
meson \
@@ -44,6 +63,14 @@ build() {
}
package() {
+ install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
+
cd "$_pkgname"
DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ for util in autoname-workspaces.py inactive-windows-transparency.py grimshot; do
+ install -Dm755 "contrib/$util" -t "$pkgdir/usr/share/$pkgname/scripts"
+ done
}