summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2015-08-16 10:19:15 -0400
committerDrew DeVault2015-08-16 10:19:15 -0400
commitc6e45dc7db3660ad05d7f9ed73282b1578d74fa8 (patch)
tree712deebe7b7e04f69ae519111de9c32c6b8c83fc
parentfe5a4989655d588016cb0e26f1190557e3c76d97 (diff)
downloadaur-c6e45dc7db3660ad05d7f9ed73282b1578d74fa8.tar.gz
Switch to VCS versioning
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc35c39b048f..24f883782c6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=sway-git
_pkgname=sway
-pkgver=1.0.0
+pkgver=r170.0d04189
pkgrel=1
license=('MIT')
pkgdesc='i3 compatible window manager for Wayland'
@@ -13,6 +13,11 @@ url='https://github.com/SirCmpwn/sway'
source=("${pkgname%-*}::git+https://github.com/SirCmpwn/sway.git")
sha1sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd "${srcdir}/${_pkgname}"