summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheo Tosini2015-12-03 20:25:47 -0500
committerTheo Tosini2015-12-03 20:31:25 -0500
commit022a61cac979f70fffba496e9610a6a53eccb206 (patch)
treef6fd74eb712dc265d8be2bf046c905a86d6e1e7c
downloadaur-022a61cac979f70fffba496e9610a6a53eccb206.tar.gz
Initial Commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD56
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..564aa2ad6688
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = swift-language-git
+ pkgdesc = The Swift programming language, taken directly from the Apple repository
+ pkgver = swift.2.2.SNAPSHOT.2015.12.01.b.r232.g273ad25
+ pkgrel = 1
+ url = https://swift.org/
+ arch = x86_64
+ license = apache2
+ makedepends = git
+ makedepends = ninja
+ source = git+https://github.com/apple/swift
+ source = llvm::git+https://github.com/apple/swift-llvm
+ source = clang::git+https://github.com/apple/swift-clang
+ source = lldb::git+https://github.com/apple/swift-lldb
+ source = cmark::git+https://github.com/apple/swift-cmark
+ source = llbuild::git+https://github.com/apple/swift-llbuild
+ source = swiftpm::git+https://github.com/apple/swift-package-manager
+ source = git+https://github.com/apple/swift-corelibs-xctest
+ source = git+https://github.com/apple/swift-corelibs-foundation
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = swift-language-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64db46044c44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Theo Tosini <theo.tosini@theoduino.me>
+pkgname=swift-language-git
+pkgver=swift.2.2.SNAPSHOT.2015.12.01.b.r232.g273ad25
+pkgrel=1
+pkgdesc="The Swift programming language, taken directly from the Apple repository"
+arch=('x86_64')
+url="https://swift.org/"
+license=('apache2')
+groups=()
+depends=()
+makedepends=('git' 'ninja')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/apple/swift'
+ 'llvm::git+https://github.com/apple/swift-llvm'
+ 'clang::git+https://github.com/apple/swift-clang'
+ 'lldb::git+https://github.com/apple/swift-lldb'
+ 'cmark::git+https://github.com/apple/swift-cmark'
+ 'llbuild::git+https://github.com/apple/swift-llbuild'
+ 'swiftpm::git+https://github.com/apple/swift-package-manager'
+ 'git+https://github.com/apple/swift-corelibs-xctest'
+ 'git+https://github.com/apple/swift-corelibs-foundation')
+noextract=()
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$pkgname/swift"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/swift"
+ # Patch to use python2
+ find . -type f -print0 | xargs -0 sed -i 's/\/usr\/bin\/env python/\/usr\/bin\/env python2/g'
+ # Release build
+ python2 utils/build-script -R
+}
+
+package() {
+ cd "$srcdir/build"
+ cp -R Ninja-ReleaseAssert $pkgdir/opt/swift
+}
+
+# vim:set ts=2 sw=2 et: