summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2022-01-17 06:41:46 +0100
committersoloturn2022-01-17 06:41:46 +0100
commit12e22cc5cc72f0a9f83229aa38c11e0b1c2d9614 (patch)
treeb372f26be4952771b23303ffc4dd8505feeff68b
parent9cee06570f6044d847e2e87c5a224a0cf864e55e (diff)
downloadaur-12e22cc5cc72f0a9f83229aa38c11e0b1c2d9614.tar.gz
update to latest SNAPSHOT
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD10
2 files changed, 26 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 586bc70083a0..f63dceacf4ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.DEVELOPMENT.SNAPSHOT.2021.10.05.a.r2611.g850426514ad
+ pkgver = swift.DEVELOPMENT.SNAPSHOT.2022.01.09.a.r228.g5a9abb2119a
pkgrel = 1
url = https://swift.org/
arch = x86_64
@@ -24,7 +24,7 @@ pkgbase = swift-language-git
source = git+https://github.com/apple/swift#branch=main
source = cmark::git+https://github.com/apple/swift-cmark#branch=main
source = llbuild::git+https://github.com/apple/swift-llbuild#branch=main
- source = swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=0.4.4
+ source = swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.0.1
source = swift-atomics::git+https://github.com/apple/swift-atomics#commit=1.0.2
source = swift-ccollections::git+https://github.com/apple/swift-collections#commit=1.0.1
source = swift-crypto::git+https://github.com/apple/swift-crypto#commit=1.1.5
@@ -33,7 +33,7 @@ pkgbase = swift-language-git
source = swift-tools-support-core::git+https://github.com/apple/swift-tools-support-core#branch=main
source = swiftpm::git+https://github.com/apple/swift-package-manager#branch=main
source = swift-syntax::git+https://github.com/apple/swift-syntax#branch=main
- source = swift-system::git+https://github.com/apple/swift-system#commit=1.0.0
+ source = swift-system::git+https://github.com/apple/swift-system#commit=1.1.1
source = swift-stress-tester::git+https://github.com/apple/swift-stress-tester#branch=main
source = swift-corelibs-xctest::git+https://github.com/apple/swift-corelibs-xctest#branch=main
source = swift-corelibs-foundation::git+https://github.com/apple/swift-corelibs-foundation#branch=main
@@ -44,8 +44,17 @@ pkgbase = swift-language-git
source = indexstore-db::git+https://github.com/apple/indexstore-db#branch=main
source = yams::git+https://github.com/jpsim/Yams#commit=4.0.2
source = sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main
+ source = swift-cmark-gfm::git+https://github.com/apple/swift-cmark#branch=gfm
+ source = swift-docc::git+https://github.com/apple/swift-docc#branch=main
+ source = swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#branch=main
+ source = swift-docc-symbolkit::git+https://github.com/apple/swift-docc-symbolkit#branch=main
+ source = swift-experimental-string-processing::git+https://github.com/apple/swift-experimental-string-processing#commit=dev/5
source = swift-format::git+https://github.com/apple/swift-format#branch=main
source = swift-installer-scripts::git+https://github.com/apple/swift-installer-scripts#branch=main
+ source = swift-lmdb::git+https://github.com/apple/swift-lmdb#branch=main
+ source = swift-markdown::git+https://github.com/apple/swift-markdown#branch=main
+ source = swift-nio::git+https://github.com/apple/swift-nio#commit=2.31.2
+ source = swift-nio-ssl::git+https://github.com/apple/swift-nio-ssl#commit=2.15.0
source = swift-tools-support-core::git+https://github.com/apple/swift-tools-support-core#branch=main
source = swift-xcode-playground-support::git+https://github.com/apple/swift-xcode-playground-support#branch=main
md5sums = SKIP
@@ -75,5 +84,14 @@ pkgbase = swift-language-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = swift-language-git
diff --git a/PKGBUILD b/PKGBUILD
index 9d5ce3cbb243..b3f22548b427 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andrew Sun <adsun701@gmail.com>
pkgname=swift-language-git
-pkgver=swift.DEVELOPMENT.SNAPSHOT.2021.10.05.a.r2611.g850426514ad
+pkgver=swift.DEVELOPMENT.SNAPSHOT.2022.01.09.a.r228.g5a9abb2119a
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')
@@ -27,7 +27,7 @@ source=(
'swift-tools-support-core::git+https://github.com/apple/swift-tools-support-core#branch=main'
'swiftpm::git+https://github.com/apple/swift-package-manager#branch=main'
'swift-syntax::git+https://github.com/apple/swift-syntax#branch=main'
- 'swift-system::git+https://github.com/apple/swift-system#commit=1.0.1'
+ 'swift-system::git+https://github.com/apple/swift-system#commit=1.1.1'
'swift-stress-tester::git+https://github.com/apple/swift-stress-tester#branch=main'
'swift-corelibs-xctest::git+https://github.com/apple/swift-corelibs-xctest#branch=main'
'swift-corelibs-foundation::git+https://github.com/apple/swift-corelibs-foundation#branch=main'
@@ -42,13 +42,13 @@ source=(
'swift-docc::git+https://github.com/apple/swift-docc#branch=main'
'swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#branch=main'
'swift-docc-symbolkit::git+https://github.com/apple/swift-docc-symbolkit#branch=main'
- 'swift-experimental-string-processing::git+https://github.com/apple/swift-experimental-string-processing#branch=dev/5'
+ 'swift-experimental-string-processing::git+https://github.com/apple/swift-experimental-string-processing#commit=dev/5'
'swift-format::git+https://github.com/apple/swift-format#branch=main'
'swift-installer-scripts::git+https://github.com/apple/swift-installer-scripts#branch=main'
'swift-lmdb::git+https://github.com/apple/swift-lmdb#branch=main'
'swift-markdown::git+https://github.com/apple/swift-markdown#branch=main'
- 'swift-nio::git+https://github.com/apple/swift-nio#branch=2.31.2'
- 'swift-nio-ssl::git+https://github.com/apple/swift-nio-ssl#branch=2.15.0'
+ 'swift-nio::git+https://github.com/apple/swift-nio#commit=2.31.2'
+ 'swift-nio-ssl::git+https://github.com/apple/swift-nio-ssl#commit=2.15.0'
'swift-tools-support-core::git+https://github.com/apple/swift-tools-support-core#branch=main'
'swift-xcode-playground-support::git+https://github.com/apple/swift-xcode-playground-support#branch=main'
)