summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-10-08 12:07:14 +0200
committersoloturn2023-10-08 12:07:14 +0200
commit18031d729182f1091c85a030b0fdf0a1eefbed6a (patch)
treed2cd270aac18014ac1199325268a0553fd6a0022
parent94b476b48bdaaec3ed50c7b55f59f0b9ec099aed (diff)
downloadaur-18031d729182f1091c85a030b0fdf0a1eefbed6a.tar.gz
prepare 5.10
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40b430efe293..1056c1f1f751 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.DEVELOPMENT.SNAPSHOT.2023.09.02.a.r9.g550a0ce12
+ pkgver = swift.DEVELOPMENT.SNAPSHOT.2023.10.07.a.r27.g254450981
pkgrel = 1
url = https://swift.org/
arch = x86_64
@@ -19,12 +19,11 @@ pkgbase = swift-language-git
depends = python
depends = libbsd
depends = ncurses
- provides = swift-language
options = !strip
source = git+https://github.com/apple/swift#branch=main
- source = cmark::git+https://github.com/apple/swift-cmark#branch=main
+ source = apple-cmark::git+https://github.com/apple/swift-cmark#branch=main
source = llbuild::git+https://github.com/apple/swift-llbuild#branch=main
- source = swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.2.2
+ source = swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.2.3
source = swift-atomics::git+https://github.com/apple/swift-atomics#commit=1.0.2
source = swift-collections::git+https://github.com/apple/swift-collections#commit=1.0.1
source = swift-crypto::git+https://github.com/apple/swift-crypto#commit=2.5.0
@@ -39,15 +38,15 @@ pkgbase = swift-language-git
source = swift-corelibs-foundation::git+https://github.com/apple/swift-corelibs-foundation#branch=main
source = swift-corelibs-libdispatch::git+https://github.com/apple/swift-corelibs-libdispatch#branch=main
source = swift-integration-tests::git+https://github.com/apple/swift-integration-tests#branch=main
- source = llvm-project::git+https://github.com/apple/llvm-project#branch=stable/20220421
+ source = apple-llvm-project::git+https://github.com/apple/llvm-project#branch=stable/20220421
source = swift-llvm-bindings::git+https://github.com/apple/swift-llvm-bindings#branch=stable/20220421
source = 0001-arch-aur-patches.patch
source = 0002-stdint.patch
source = indexstore-db::git+https://github.com/apple/indexstore-db#branch=main
source = yams::git+https://github.com/jpsim/Yams#commit=5.0.1
source = sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main
- source = swift-asn1::git+https://github.com/apple/swift-asn1#commit=0.7.0
- source = swift-certificates::git+https://github.com/apple/swift-certificates#commit=0.4.1
+ source = swift-asn1::git+https://github.com/apple/swift-asn1#commit=0.8.0
+ source = swift-certificates::git+https://github.com/apple/swift-certificates#commit=0.6.0
source = swift-cmark::git+https://github.com/apple/swift-cmark#branch=gfm
source = swift-docc::git+https://github.com/apple/swift-docc#branch=main
source = swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#branch=main
diff --git a/PKGBUILD b/PKGBUILD
index dd0327216e90..10db2f87b2b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andrew Sun <adsun701@gmail.com>
pkgname=swift-language-git
-pkgver=swift.DEVELOPMENT.SNAPSHOT.2023.09.02.a.r9.g550a0ce12
+pkgver=swift.DEVELOPMENT.SNAPSHOT.2023.10.07.a.r27.g254450981
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')
@@ -13,12 +13,11 @@ url="https://swift.org/"
license=('apache2')
depends=('icu' 'libedit' 'libxml2' 'python' 'libbsd' 'ncurses' )
makedepends=('clang' 'cmake' 'git' 'ninja' 'patch' 'python-six' 'rsync' 'swig')
-provides=('swift-language')
source=(
'git+https://github.com/apple/swift#branch=main'
- 'cmark::git+https://github.com/apple/swift-cmark#branch=main'
+ 'apple-cmark::git+https://github.com/apple/swift-cmark#branch=main'
'llbuild::git+https://github.com/apple/swift-llbuild#branch=main'
- 'swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.2.2'
+ 'swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.2.3'
'swift-atomics::git+https://github.com/apple/swift-atomics#commit=1.0.2'
'swift-collections::git+https://github.com/apple/swift-collections#commit=1.0.1'
'swift-crypto::git+https://github.com/apple/swift-crypto#commit=2.5.0'
@@ -33,15 +32,15 @@ source=(
'swift-corelibs-foundation::git+https://github.com/apple/swift-corelibs-foundation#branch=main'
'swift-corelibs-libdispatch::git+https://github.com/apple/swift-corelibs-libdispatch#branch=main'
'swift-integration-tests::git+https://github.com/apple/swift-integration-tests#branch=main'
- 'llvm-project::git+https://github.com/apple/llvm-project#branch=stable/20220421'
+ 'apple-llvm-project::git+https://github.com/apple/llvm-project#branch=stable/20220421'
'swift-llvm-bindings::git+https://github.com/apple/swift-llvm-bindings#branch=stable/20220421'
'0001-arch-aur-patches.patch'
'0002-stdint.patch'
'indexstore-db::git+https://github.com/apple/indexstore-db#branch=main'
'yams::git+https://github.com/jpsim/Yams#commit=5.0.1'
'sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main'
- 'swift-asn1::git+https://github.com/apple/swift-asn1#commit=0.7.0'
- 'swift-certificates::git+https://github.com/apple/swift-certificates#commit=0.4.1'
+ 'swift-asn1::git+https://github.com/apple/swift-asn1#commit=0.8.0'
+ 'swift-certificates::git+https://github.com/apple/swift-certificates#commit=0.6.0'
'swift-cmark::git+https://github.com/apple/swift-cmark#branch=gfm'
'swift-docc::git+https://github.com/apple/swift-docc#branch=main'
'swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#branch=main'