summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheo Tosini2015-12-03 22:49:10 -0500
committerTheo Tosini2015-12-03 22:49:10 -0500
commit3e6689fb89c6a2f3727434e5e217370c38c41c95 (patch)
tree4fffdb705d342331abbfe7a91fab571a7e150ccc
parent022a61cac979f70fffba496e9610a6a53eccb206 (diff)
downloadaur-3e6689fb89c6a2f3727434e5e217370c38c41c95.tar.gz
Fixed a -lpthread and -ldl error
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 564aa2ad6688..0494b11fc317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,20 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.2.2.SNAPSHOT.2015.12.01.b.r232.g273ad25
+ pkgver = swift.2.2.SNAPSHOT.2015.12.01.b.r258.g3de382e
pkgrel = 1
url = https://swift.org/
arch = x86_64
license = apache2
makedepends = git
makedepends = ninja
+ makedepends = cmake
+ makedepends = clang
+ depends = icu
+ depends = libedit
+ depends = libxml2
+ depends = swig
+ depends = python2
+ depends = libbsd
source = git+https://github.com/apple/swift
source = llvm::git+https://github.com/apple/swift-llvm
source = clang::git+https://github.com/apple/swift-clang
diff --git a/PKGBUILD b/PKGBUILD
index 64db46044c44..8792592908cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Theo Tosini <theo.tosini@theoduino.me>
pkgname=swift-language-git
-pkgver=swift.2.2.SNAPSHOT.2015.12.01.b.r232.g273ad25
+pkgver=swift.2.2.SNAPSHOT.2015.12.01.b.r258.g3de382e
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')
url="https://swift.org/"
license=('apache2')
groups=()
-depends=()
-makedepends=('git' 'ninja')
+depends=('icu' 'libedit' 'libxml2' 'swig' 'python2' 'libbsd')
+makedepends=('git' 'ninja' 'cmake' 'clang')
provides=()
conflicts=()
replaces=()
@@ -36,7 +36,7 @@ md5sums=('SKIP'
'SKIP')
pkgver() {
- cd "$pkgname/swift"
+ cd "$srcdir/swift"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
@@ -45,12 +45,14 @@ build() {
# Patch to use python2
find . -type f -print0 | xargs -0 sed -i 's/\/usr\/bin\/env python/\/usr\/bin\/env python2/g'
# Release build
- python2 utils/build-script -R
+ LDFLAGS='-ldl -lpthread' python2 utils/build-script -R
}
package() {
cd "$srcdir/build"
- cp -R Ninja-ReleaseAssert $pkgdir/opt/swift
+ mkdir -p '$pkgdir/opt'
+ cp -R Ninja-ReleaseAssert '$pkgdir/opt/swift'
+ ln -s /opt/swift/swift-linux-$CARCH/bin/{lldb-moduleimport-test,sil-extract,sil-opt,swift,swift-autolink-extract,swiftc,swift-demangle,swift-ide-test,swift-llvm-opt} '$pkgdir/usr/bin'
}
# vim:set ts=2 sw=2 et: