summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-05-12 06:54:17 +0200
committersoloturn2023-05-12 06:54:17 +0200
commit87b5fdca1a4857813e9a762411e6d2ffbd047631 (patch)
tree102de9a83355011e831244c43d08bdd3158a9e79
parent2aee8381c871668cdac889a180ea717054a158d7 (diff)
downloadaur-87b5fdca1a4857813e9a762411e6d2ffbd047631.tar.gz
update to latest, 5.9 dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD12
3 files changed, 20 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b1c96c977a2..7ba3aa2ffecd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = swift-language-git
pkgdesc = The Swift programming language, taken directly from the Apple repository
- pkgver = swift.DEVELOPMENT.SNAPSHOT.2023.02.03.a.r27.gc29abfb59
+ pkgver = swift.DEVELOPMENT.SNAPSHOT.2023.02.06.a.r12.g5d684fb67
pkgrel = 1
url = https://swift.org/
arch = x86_64
@@ -24,10 +24,10 @@ pkgbase = swift-language-git
source = git+https://github.com/apple/swift#branch=main
source = cmark::git+https://github.com/apple/swift-cmark#branch=main
source = llbuild::git+https://github.com/apple/swift-llbuild#branch=main
- source = swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.1.4
+ source = swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.2.2
source = swift-atomics::git+https://github.com/apple/swift-atomics#commit=1.0.2
source = swift-collections::git+https://github.com/apple/swift-collections#commit=1.0.1
- source = swift-crypto::git+https://github.com/apple/swift-crypto#commit=2.2.3
+ source = swift-crypto::git+https://github.com/apple/swift-crypto#commit=2.5.0
source = swift-driver::git+https://github.com/apple/swift-driver#branch=main
source = swift-numerics::git+https://github.com/apple/swift-numerics#commit=1.0.1
source = swift-tools-support-core::git+https://github.com/apple/swift-tools-support-core#branch=main
@@ -45,7 +45,9 @@ pkgbase = swift-language-git
source = indexstore-db::git+https://github.com/apple/indexstore-db#branch=main
source = yams::git+https://github.com/jpsim/Yams#commit=5.0.1
source = sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main
- source = swift-cmark-gfm::git+https://github.com/apple/swift-cmark#branch=gfm
+ source = swift-asn1::git+https://github.com/apple/swift-asn1#commit=0.7.0
+ source = swift-certificates::git+https://github.com/apple/swift-certificates#commit=0.4.1
+ source = swift-cmark::git+https://github.com/apple/swift-cmark#branch=gfm
source = swift-docc::git+https://github.com/apple/swift-docc#branch=main
source = swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#branch=main
source = swift-docc-symbolkit::git+https://github.com/apple/swift-docc-symbolkit#branch=main
@@ -95,5 +97,7 @@ pkgbase = swift-language-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = swift-language-git
diff --git a/.gitignore b/.gitignore
index 417a7005a72d..fa93102d9bec 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,9 +7,11 @@
/llbuild/
/llvm-project/
/sourcekit-lsp/
+/swift-asn1/
/swift-argument-parser/
/swift-atomics/
-/swift-cmark-gfm/
+/swift-certificates/
+/swift-cmark/
/swift-collections/
/swift-corelibs-foundation/
/swift-corelibs-libdispatch/
@@ -39,3 +41,4 @@
/yams/
+
diff --git a/PKGBUILD b/PKGBUILD
index 168a28b3dc95..e81fbb33a3e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andrew Sun <adsun701@gmail.com>
pkgname=swift-language-git
-pkgver=swift.DEVELOPMENT.SNAPSHOT.2023.02.03.a.r27.gc29abfb59
+pkgver=swift.DEVELOPMENT.SNAPSHOT.2023.02.06.a.r12.g5d684fb67
pkgrel=1
pkgdesc="The Swift programming language, taken directly from the Apple repository"
arch=('x86_64')
@@ -18,10 +18,10 @@ source=(
'git+https://github.com/apple/swift#branch=main'
'cmark::git+https://github.com/apple/swift-cmark#branch=main'
'llbuild::git+https://github.com/apple/swift-llbuild#branch=main'
- 'swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.1.4'
+ 'swift-argument-parser::git+https://github.com/apple/swift-argument-parser#commit=1.2.2'
'swift-atomics::git+https://github.com/apple/swift-atomics#commit=1.0.2'
'swift-collections::git+https://github.com/apple/swift-collections#commit=1.0.1'
- 'swift-crypto::git+https://github.com/apple/swift-crypto#commit=2.2.3'
+ 'swift-crypto::git+https://github.com/apple/swift-crypto#commit=2.5.0'
'swift-driver::git+https://github.com/apple/swift-driver#branch=main'
'swift-numerics::git+https://github.com/apple/swift-numerics#commit=1.0.1'
'swift-tools-support-core::git+https://github.com/apple/swift-tools-support-core#branch=main'
@@ -39,7 +39,9 @@ source=(
'indexstore-db::git+https://github.com/apple/indexstore-db#branch=main'
'yams::git+https://github.com/jpsim/Yams#commit=5.0.1'
'sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main'
- 'swift-cmark-gfm::git+https://github.com/apple/swift-cmark#branch=gfm'
+ 'swift-asn1::git+https://github.com/apple/swift-asn1#commit=0.7.0'
+ 'swift-certificates::git+https://github.com/apple/swift-certificates#commit=0.4.1'
+ 'swift-cmark::git+https://github.com/apple/swift-cmark#branch=gfm'
'swift-docc::git+https://github.com/apple/swift-docc#branch=main'
'swift-docc-render-artifact::git+https://github.com/apple/swift-docc-render-artifact#branch=main'
'swift-docc-symbolkit::git+https://github.com/apple/swift-docc-symbolkit#branch=main'
@@ -92,6 +94,8 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
)