summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2020-06-07 16:45:05 +0200
committersoloturn2020-06-07 16:45:05 +0200
commit8e31deb3cb5a62afa81f7e309ed7b7b8f894dea3 (patch)
treea12ccbb41f27d0a639dbc0c5f1198ee5dae0331e
parenta219d33a8f02937d5662c518e22811f5dcd3fba4 (diff)
downloadaur-8e31deb3cb5a62afa81f7e309ed7b7b8f894dea3.tar.gz
pyton instead of python2
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b271b7a3a15..d1271cd7942b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=('x86_64')
url="https://swift.org/"
license=('apache2')
groups=()
-depends=('icu' 'libedit' 'libxml2' 'swig' 'python2' 'libbsd' 'ncurses' )
+depends=('icu' 'libedit' 'libxml2' 'swig' 'python' 'libbsd' 'ncurses' )
makedepends=('git' 'ninja' 'cmake' 'clang')
provides=('swift-language')
conflicts=('swift-language-bin')
@@ -54,17 +54,15 @@ pkgver() {
build() {
cd "$srcdir/swift"
- # Patch to use python2
- find "$srcdir" -type f -print0 | xargs -0 sed -i 's/\/usr\/bin\/env python/\/usr\/bin\/env python2/g'
# Fix /usr/include error
find "$srcdir" -type f -print0 | xargs -0 sed -i 's|/usr/include/x86_64-linux-gnu|/usr/include|g'
# Release build
- LDFLAGS='-ldl -lpthread' python2 utils/build-script -b -p --foundation --xctest -R
+ LDFLAGS='-ldl -lpthread' python utils/build-script -b -p --foundation --xctest -R
}
check() {
cd "$srcdir/swift"
- python2 utils/build-script -t
+ python utils/build-script -t
}
package() {