summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2023-05-20 12:54:34 +0200
committersoloturn2023-05-20 12:54:34 +0200
commitdbf69c3ae7a7dfbdcd2018e5f52c90ce0b8973b9 (patch)
tree84752ce92570dc2a4a342644db98e313856c5880
parent87b5fdca1a4857813e9a762411e6d2ffbd047631 (diff)
downloadaur-dbf69c3ae7a7dfbdcd2018e5f52c90ce0b8973b9.tar.gz
patch llvm-project Signals.h from upstream
-rw-r--r--.SRCINFO2
-rw-r--r--0002-stdint.patch12
-rw-r--r--PKGBUILD3
3 files changed, 17 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ba3aa2ffecd..24e3f864a910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -42,6 +42,7 @@ pkgbase = swift-language-git
source = llvm-project::git+https://github.com/apple/llvm-project#branch=stable/20220421
source = swift-llvm-bindings::git+https://github.com/apple/swift-llvm-bindings#branch=stable/20220421
source = 0001-arch-aur-patches.patch
+ source = 0002-stdint.patch
source = indexstore-db::git+https://github.com/apple/indexstore-db#branch=main
source = yams::git+https://github.com/jpsim/Yams#commit=5.0.1
source = sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main
@@ -99,5 +100,6 @@ pkgbase = swift-language-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = swift-language-git
diff --git a/0002-stdint.patch b/0002-stdint.patch
new file mode 100644
index 000000000000..f18fd140620c
--- /dev/null
+++ b/0002-stdint.patch
@@ -0,0 +1,12 @@
+diff --git a/llvm/include/llvm/Support/Signals.h b/llvm/include/llvm/Support/Signals.h
+index 44f5a750ff5..937e0572d4a 100644
+--- a/llvm/include/llvm/Support/Signals.h
++++ b/llvm/include/llvm/Support/Signals.h
+@@ -14,6 +14,7 @@
+ #ifndef LLVM_SUPPORT_SIGNALS_H
+ #define LLVM_SUPPORT_SIGNALS_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace llvm {
diff --git a/PKGBUILD b/PKGBUILD
index e81fbb33a3e7..0a394451a916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,6 +36,7 @@ source=(
'llvm-project::git+https://github.com/apple/llvm-project#branch=stable/20220421'
'swift-llvm-bindings::git+https://github.com/apple/swift-llvm-bindings#branch=stable/20220421'
'0001-arch-aur-patches.patch'
+ '0002-stdint.patch'
'indexstore-db::git+https://github.com/apple/indexstore-db#branch=main'
'yams::git+https://github.com/jpsim/Yams#commit=5.0.1'
'sourcekit-lsp::git+https://github.com/apple/sourcekit-lsp#branch=main'
@@ -96,6 +97,7 @@ md5sums=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
@@ -108,6 +110,7 @@ options=(!strip)
prepare () {
( cd swift && patch -p1 -i "$srcdir/0001-arch-aur-patches.patch" )
+ ( cd llvm-project && patch -p1 -i "$srcdir/0002-stdint.patch" )
}
pkgver() {